aboutsummaryrefslogtreecommitdiff
path: root/graphics/rawtherapee
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2011-08-20 01:53:49 +0000
committerStanislav Sedov <stas@FreeBSD.org>2011-08-20 01:53:49 +0000
commit6261e26750786400da28247714d7c112a44a59ca (patch)
treedaa0212278647b20a992361e2d87589bf24bb868 /graphics/rawtherapee
parent78527e36cd8e64f6c4203480edd35f2de137b28a (diff)
Notes
Diffstat (limited to 'graphics/rawtherapee')
-rw-r--r--graphics/rawtherapee/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/graphics/rawtherapee/Makefile b/graphics/rawtherapee/Makefile
index 1e69500036a7..017fada3e498 100644
--- a/graphics/rawtherapee/Makefile
+++ b/graphics/rawtherapee/Makefile
@@ -17,7 +17,7 @@ COMMENT= A powerful RAW image processing application
LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
iptcdata.3:${PORTSDIR}/graphics/libiptcdata \
jpeg.11:${PORTSDIR}/graphics/jpeg \
- lcms2.2:${PORTSDIR}/graphics/lcms2 \
+ lcms.1:${PORTSDIR}/graphics/lcms \
png:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
sigc-2.0:${PORTSDIR}/devel/libsigc++20
@@ -42,7 +42,8 @@ LICENSE= GPLv3
RTDIR= ${PREFIX}/libdata/${PORTNAME}
-OPTIONS= OPTIMIZED_CFLAGS "Use optimized CFLAGS" on
+OPTIONS= OPTIMIZED_CFLAGS "Use optimized CFLAGS" on \
+ OPENMP "Enable multicore processing using OpenMP" on
.include <bsd.port.pre.mk>
@@ -53,4 +54,10 @@ CFLAGS+= -O3 -ffast-math -fexpensive-optimizations \
.endif
.endif
+.if !defined(WITHOUT_OPENMP)
+CMAKE_ARGS+= -DOPTION_OMP:BOOL=ON
+.else
+CMAKE_ARGS+= -DOPTION_OMP:BOOL=OFF
+.endif
+
.include <bsd.port.post.mk>