aboutsummaryrefslogtreecommitdiff
path: root/graphics/rawtherapee
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-04-26 04:39:06 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-04-26 04:39:06 +0000
commitcfd16bcb66120b13fdd4fb0aebc951b9de8487a8 (patch)
treee3d3429730d56c60436b922f518774b1052943c1 /graphics/rawtherapee
parent7237b72d74247bd339b6e0af032d23c8184adc70 (diff)
downloadports-cfd16bcb66120b13fdd4fb0aebc951b9de8487a8.tar.gz
ports-cfd16bcb66120b13fdd4fb0aebc951b9de8487a8.zip
Notes
Diffstat (limited to 'graphics/rawtherapee')
-rw-r--r--graphics/rawtherapee/Makefile2
-rw-r--r--graphics/rawtherapee/distinfo4
-rw-r--r--graphics/rawtherapee/files/patch-rtengine-CA__correct__RT.c20
-rw-r--r--graphics/rawtherapee/files/patch-rtengine_array2D.h33
-rw-r--r--graphics/rawtherapee/pkg-plist40
5 files changed, 41 insertions, 58 deletions
diff --git a/graphics/rawtherapee/Makefile b/graphics/rawtherapee/Makefile
index 56f706156a7a..7e2ddb4a44dc 100644
--- a/graphics/rawtherapee/Makefile
+++ b/graphics/rawtherapee/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= rawtherapee
-PORTVERSION= 4.0.7
+PORTVERSION= 4.0.8
CATEGORIES= graphics
MASTER_SITES= GOOGLE_CODE
diff --git a/graphics/rawtherapee/distinfo b/graphics/rawtherapee/distinfo
index 1ce9237270a1..66d8d8f96b62 100644
--- a/graphics/rawtherapee/distinfo
+++ b/graphics/rawtherapee/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rawtherapee-4.0.7.tar.xz) = 53ee32679389b52392ff03284ebc76f89e3476ec1fc30a8405817f8a2a0659c8
-SIZE (rawtherapee-4.0.7.tar.xz) = 34647976
+SHA256 (rawtherapee-4.0.8.tar.xz) = b0cbeac634d927b6afc0527434b24304b9d1ab2a681915933a872cf1a27f39cd
+SIZE (rawtherapee-4.0.8.tar.xz) = 40766264
diff --git a/graphics/rawtherapee/files/patch-rtengine-CA__correct__RT.c b/graphics/rawtherapee/files/patch-rtengine-CA__correct__RT.c
deleted file mode 100644
index 233d7c378383..000000000000
--- a/graphics/rawtherapee/files/patch-rtengine-CA__correct__RT.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./rtengine/CA_correct_RT.cc.orig 2012-01-31 05:00:05.000000000 +0400
-+++ ./rtengine/CA_correct_RT.cc 2012-03-30 13:23:58.000000000 +0400
-@@ -467,7 +467,7 @@
- gdiff=0.3125*(rgb[indx+TS][1]-rgb[indx-TS][1])+0.09375*(rgb[indx+TS+1][1]-rgb[indx-TS+1][1]+rgb[indx+TS-1][1]-rgb[indx-TS-1][1]);
- deltgrb=(rgb[indx][c]-rgb[indx][1])-0.5*((rgb[indx-v4][c]-rgb[indx-v4][1])+(rgb[indx+v4][c]-rgb[indx+v4][1]));
-
-- gradwt=fabs(0.25*rbhpfv[indx]+0.125*(rbhpfv[indx+2]+rbhpfv[indx-2]) );//*(grblpfv[indx-v2]+grblpfv[indx+v2])/(eps+0.1*grblpfv[indx-v2]+rblpfv[indx-v2]+0.1*grblpfv[indx+v2]+rblpfv[indx+v2]);
-+ gradwt=fabs(0.25*rbhpfv[indx]+0.125*(rbhpfv[indx+2]+rbhpfv[indx-2]) );// *(grblpfv[indx-v2]+grblpfv[indx+v2])/(eps+0.1*grblpfv[indx-v2]+rblpfv[indx-v2]+0.1*grblpfv[indx+v2]+rblpfv[indx+v2]);
- if (gradwt>eps) {
- coeff[0][0][c] += gradwt*deltgrb*deltgrb;
- coeff[0][1][c] += gradwt*gdiff*deltgrb;
-@@ -479,7 +479,7 @@
- gdiff=0.3125*(rgb[indx+1][1]-rgb[indx-1][1])+0.09375*(rgb[indx+1+TS][1]-rgb[indx-1+TS][1]+rgb[indx+1-TS][1]-rgb[indx-1-TS][1]);
- deltgrb=(rgb[indx][c]-rgb[indx][1])-0.5*((rgb[indx-4][c]-rgb[indx-4][1])+(rgb[indx+4][c]-rgb[indx+4][1]));
-
-- gradwt=fabs(0.25*rbhpfh[indx]+0.125*(rbhpfh[indx+v2]+rbhpfh[indx-v2]) );//*(grblpfh[indx-2]+grblpfh[indx+2])/(eps+0.1*grblpfh[indx-2]+rblpfh[indx-2]+0.1*grblpfh[indx+2]+rblpfh[indx+2]);
-+ gradwt=fabs(0.25*rbhpfh[indx]+0.125*(rbhpfh[indx+v2]+rbhpfh[indx-v2]) );// *(grblpfh[indx-2]+grblpfh[indx+2])/(eps+0.1*grblpfh[indx-2]+rblpfh[indx-2]+0.1*grblpfh[indx+2]+rblpfh[indx+2]);
- if (gradwt>eps) {
- coeff[1][0][c] += gradwt*deltgrb*deltgrb;
- coeff[1][1][c] += gradwt*gdiff*deltgrb;
diff --git a/graphics/rawtherapee/files/patch-rtengine_array2D.h b/graphics/rawtherapee/files/patch-rtengine_array2D.h
deleted file mode 100644
index e5d4a1ecbbb6..000000000000
--- a/graphics/rawtherapee/files/patch-rtengine_array2D.h
+++ /dev/null
@@ -1,33 +0,0 @@
---- ./rtengine/array2D.h.orig 2012-01-31 05:00:05.000000000 +0400
-+++ ./rtengine/array2D.h 2012-03-30 13:26:24.000000000 +0400
-@@ -156,7 +156,7 @@
- }
-
- // use with indices
-- T * operator[](size_t index) {
-+ T * operator[](int index) {
- assert(index<y);
- return ptr[index];
- }
-@@ -252,7 +252,7 @@
-
- public:
- multi_array2D(int x, int y, int flags = 0) {
-- for (int i = 0; i < num; i++)
-+ for (size_t i = 0; i < num; i++)
- list[i](x, y, flags);
- }
-
-@@ -260,9 +260,9 @@
- //printf("trying to delete the list of array2D objects\n");
- }
-
-- array2D<T> & operator[](size_t index) {
-- if (index >= num) {
-- printf("index %zu is out of range[0..%zu]", index, num - 1);
-+ array2D<T> & operator[](int index) {
-+ if (static_cast<size_t>(index) >= num) {
-+ printf("index %0u is out of range[0..%0u]", index, num - 1);
- raise( SIGSEGV);
- }
- return list[index];
diff --git a/graphics/rawtherapee/pkg-plist b/graphics/rawtherapee/pkg-plist
index 0313a70aa3a5..6de07be774b5 100644
--- a/graphics/rawtherapee/pkg-plist
+++ b/graphics/rawtherapee/pkg-plist
@@ -10,7 +10,40 @@ share/icons/hicolor/24x24/apps/rawtherapee.png
share/icons/hicolor/256x256/apps/rawtherapee.png
share/icons/hicolor/32x32/apps/rawtherapee.png
share/icons/hicolor/48x48/apps/rawtherapee.png
+%%DATADIR%%/dcpprofiles/Canon EOS 20D.dcp
+%%DATADIR%%/dcpprofiles/Canon EOS 400D.dcp
+%%DATADIR%%/dcpprofiles/Canon EOS 40D.dcp
+%%DATADIR%%/dcpprofiles/Canon EOS 450D.dcp
+%%DATADIR%%/dcpprofiles/Canon EOS 550D.dcp
+%%DATADIR%%/dcpprofiles/Canon EOS 5D.dcp
+%%DATADIR%%/dcpprofiles/Canon EOS 7D.dcp
+%%DATADIR%%/dcpprofiles/Canon EOS D60.dcp
+%%DATADIR%%/dcpprofiles/Canon EOS-1D Mark III.dcp
+%%DATADIR%%/dcpprofiles/Canon PowerShot G10.dcp
+%%DATADIR%%/dcpprofiles/Canon PowerShot G12.dcp
+%%DATADIR%%/dcpprofiles/Nikon D200.dcp
+%%DATADIR%%/dcpprofiles/Nikon D300.dcp
+%%DATADIR%%/dcpprofiles/Nikon D3000.dcp
+%%DATADIR%%/dcpprofiles/Nikon D3100.dcp
+%%DATADIR%%/dcpprofiles/Nikon D3S.dcp
+%%DATADIR%%/dcpprofiles/Nikon D50.dcp
+%%DATADIR%%/dcpprofiles/Nikon D700.dcp
+%%DATADIR%%/dcpprofiles/Olympus E-1.dcp
+%%DATADIR%%/dcpprofiles/Olympus E-P2.dcp
+%%DATADIR%%/dcpprofiles/Panasonic DMC-FZ150.dcp
+%%DATADIR%%/dcpprofiles/Panasonic DMC-FZ38.dcp
+%%DATADIR%%/dcpprofiles/Panasonic DMC-G1.dcp
+%%DATADIR%%/dcpprofiles/Panasonic DMC-G3.dcp
+%%DATADIR%%/dcpprofiles/Panasonic DMC-GH1.dcp
+%%DATADIR%%/dcpprofiles/Panasonic DMC-GH2.dcp
+%%DATADIR%%/dcpprofiles/Pentax K10D.dcp
+%%DATADIR%%/dcpprofiles/Pentax K200D.dcp
+%%DATADIR%%/dcpprofiles/Sony DSLR-A700.dcp
+%%DATADIR%%/dcpprofiles/Sony DSLR-A900.dcp
+%%DATADIR%%/dcpprofiles/Sony NEX-5N.dcp
+%%DATADIR%%/dcpprofiles/Sony SLT-A55V.dcp
%%DATADIR%%/iccprofiles/input/Canon EOS 20D.icc
+%%DATADIR%%/iccprofiles/input/Canon EOS 40D.icc
%%DATADIR%%/iccprofiles/input/Canon EOS 450D.icc
%%DATADIR%%/iccprofiles/input/Canon EOS 550D.icc
%%DATADIR%%/iccprofiles/input/Canon EOS 5D.icc
@@ -18,7 +51,9 @@ share/icons/hicolor/48x48/apps/rawtherapee.png
%%DATADIR%%/iccprofiles/input/Canon EOS Rebel T2i.icc
%%DATADIR%%/iccprofiles/input/Canon EOS-1D Mark III.icc
%%DATADIR%%/iccprofiles/input/Canon PowerShot G10.icc
+%%DATADIR%%/iccprofiles/input/Canon PowerShot G12.icc
%%DATADIR%%/iccprofiles/input/Nikon D200.icc
+%%DATADIR%%/iccprofiles/input/Nikon D3000.icc
%%DATADIR%%/iccprofiles/input/Nikon D3100.icc
%%DATADIR%%/iccprofiles/input/Nikon D3S.icc
%%DATADIR%%/iccprofiles/input/Nikon D700.icc
@@ -33,6 +68,8 @@ share/icons/hicolor/48x48/apps/rawtherapee.png
%%DATADIR%%/iccprofiles/input/Panasonic DMC-GH2.icc
%%DATADIR%%/iccprofiles/input/Pentax K200D.icc
%%DATADIR%%/iccprofiles/input/Sony DSLR-A700.icc
+%%DATADIR%%/iccprofiles/input/Sony DSLR-A900.icc
+%%DATADIR%%/iccprofiles/input/Sony SLT-A55V.icc
%%DATADIR%%/iccprofiles/output/RT_Large_g10.icc
%%DATADIR%%/iccprofiles/output/RT_Large_gBT709.icc
%%DATADIR%%/iccprofiles/output/RT_Large_gsRGB.icc
@@ -525,8 +562,6 @@ share/icons/hicolor/48x48/apps/rawtherapee.png
%%DATADIR%%/languages/Dansk
%%DATADIR%%/languages/Deutsch
%%DATADIR%%/languages/English
-%%DATADIR%%/languages/English (UK)
-%%DATADIR%%/languages/English (US)
%%DATADIR%%/languages/Espanol
%%DATADIR%%/languages/Euskara
%%DATADIR%%/languages/Francais
@@ -639,6 +674,7 @@ share/icons/hicolor/48x48/apps/rawtherapee.png
@dirrm %%DATADIR%%/iccprofiles/output
@dirrm %%DATADIR%%/iccprofiles/input
@dirrm %%DATADIR%%/iccprofiles
+@dirrm %%DATADIR%%/dcpprofiles
@dirrm %%DATADIR%%
@dirrm %%DOCSDIR%%
@dirrmtry share/applications