aboutsummaryrefslogtreecommitdiff
path: root/graphics/ray++
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2011-02-04 21:03:15 +0000
committerRene Ladan <rene@FreeBSD.org>2011-02-04 21:03:15 +0000
commit60aef42534e526f76b78a36437b33fe1f99f88b5 (patch)
treef421df162dabb9e02f0de02a1fab4fb58ca725fb /graphics/ray++
parentb6b2c46bf6192d2ddc4624723fc4ee18e064f902 (diff)
Notes
Diffstat (limited to 'graphics/ray++')
-rw-r--r--graphics/ray++/Makefile44
-rw-r--r--graphics/ray++/distinfo3
-rw-r--r--graphics/ray++/pkg-descr5
-rw-r--r--graphics/ray++/pkg-plist102
4 files changed, 0 insertions, 154 deletions
diff --git a/graphics/ray++/Makefile b/graphics/ray++/Makefile
deleted file mode 100644
index 74a02701257c..000000000000
--- a/graphics/ray++/Makefile
+++ /dev/null
@@ -1,44 +0,0 @@
-# ex:ts=8
-# New ports collection makefile for: ray++
-# Date created: Dec 6, 2001
-# Whom: ijliao
-#
-# $FreeBSD$
-#
-
-PORTNAME= ray++
-PORTVERSION= 0.4
-PORTREVISION= 1
-CATEGORIES= graphics
-MASTER_SITES= SF/raypp/raypp/${PORTVERSION}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A collection of C++ classes needed for ray tracing
-
-DEPRECATED= Does not compile on supported versions of FreeBSD
-EXPIRATION_DATE=2011-02-04
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-shared --enable-fast-handles
-USE_GMAKE= yes
-USE_LDCONFIG= yes
-
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} != "i386"
-BROKEN= Does not compile on !i386
-.endif
-
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
-post-patch:
- ${REINPLACE_CMD} -e "s,-pedantic,," ${WRKSRC}/configure
-
-do-install:
- @(cd ${WRKSRC} ; \
- ${INSTALL_DATA} ray++.so ${PREFIX}/lib ; \
- ${FIND} * -name "*.h" | ${CPIO} -pdum ${PREFIX}/include/${PORTNAME}; \
- ${CHMOD} -R 755 ${PREFIX}/include/${PORTNAME} )
-
-.include <bsd.port.post.mk>
diff --git a/graphics/ray++/distinfo b/graphics/ray++/distinfo
deleted file mode 100644
index 41166320acc8..000000000000
--- a/graphics/ray++/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 (ray++-0.4.tar.gz) = b9b9a071b4e24a80b878810a2218e21e
-SHA256 (ray++-0.4.tar.gz) = 63fd3369ed2da4807a1df1bb080a4bf490f8b286ece53f5509ff3ed706fe428a
-SIZE (ray++-0.4.tar.gz) = 99964
diff --git a/graphics/ray++/pkg-descr b/graphics/ray++/pkg-descr
deleted file mode 100644
index b2bf4e595149..000000000000
--- a/graphics/ray++/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-RAY++ is a collection of C++ classes needed for ray tracing (shapes,
-surfaces, cameras etc.). The object-oriented design makes it easy to
-extend the package.
-
-WWW: http://raypp.sourceforge.net
diff --git a/graphics/ray++/pkg-plist b/graphics/ray++/pkg-plist
deleted file mode 100644
index 5873d1bddaed..000000000000
--- a/graphics/ray++/pkg-plist
+++ /dev/null
@@ -1,102 +0,0 @@
-include/ray++/cameras/stereo_camera.h
-include/ray++/cameras/std_camera.h
-include/ray++/config/config.h
-include/ray++/config/sizecalc.h
-include/ray++/kernel/interval.h
-include/ray++/kernel/constants.h
-include/ray++/kernel/transformable.h
-include/ray++/kernel/ray.h
-include/ray++/kernel/bstream.h
-include/ray++/kernel/renderer.h
-include/ray++/kernel/geom_ray.h
-include/ray++/kernel/full_shading_info.h
-include/ray++/kernel/light.h
-include/ray++/kernel/shape.h
-include/ray++/kernel/initable.h
-include/ray++/kernel/object_queue.h
-include/ray++/kernel/vector.h
-include/ray++/kernel/msg_stream.h
-include/ray++/kernel/error.h
-include/ray++/kernel/intersect_info.h
-include/ray++/kernel/handle.h
-include/ray++/kernel/camera.h
-include/ray++/kernel/colour.h
-include/ray++/kernel/output.h
-include/ray++/kernel/byteswap.h
-include/ray++/kernel/surface.h
-include/ray++/kernel/countable_new.h
-include/ray++/kernel/object.h
-include/ray++/kernel/transform.h
-include/ray++/kernel/globals.h
-include/ray++/kernel/inside_info.h
-include/ray++/kernel/kernel.h
-include/ray++/kernel/shading_info.h
-include/ray++/kernel/volume.h
-include/ray++/kernel/light_array.h
-include/ray++/kernel/world.h
-include/ray++/kernel/axisbox.h
-include/ray++/lights/fuzprojector.h
-include/ray++/lights/spotlight.h
-include/ray++/lights/projector.h
-include/ray++/lights/ambient_light.h
-include/ray++/lights/pointlight.h
-include/ray++/objects/bounding_slab.h
-include/ray++/objects/simple_object.h
-include/ray++/outputs/tga_output.h
-include/ray++/outputs/ppm_output.h
-include/ray++/outputs/mem_output.h
-include/ray++/outputs/bmp_output.h
-include/ray++/renderers/raytracer.h
-include/ray++/shapes/quadric.h
-include/ray++/shapes/box.h
-include/ray++/shapes/sphere.h
-include/ray++/shapes/parametric.h
-include/ray++/shapes/clip.h
-include/ray++/shapes/cone.h
-include/ray++/shapes/solid_shape.h
-include/ray++/shapes/cylinder.h
-include/ray++/shapes/tube.h
-include/ray++/shapes/flat_shape.h
-include/ray++/shapes/plane.h
-include/ray++/shapes/triangle.h
-include/ray++/shapes/csg_shape.h
-include/ray++/shapes/implicit.h
-include/ray++/surfaces/matte.h
-include/ray++/surfaces/pigments/pure_colour.h
-include/ray++/surfaces/pigments/pigment.h
-include/ray++/surfaces/pigments/std_pigments.h
-include/ray++/surfaces/pigments/generic_pigment.h
-include/ray++/surfaces/pigments/solid_pigment.h
-include/ray++/surfaces/lambert.h
-include/ray++/surfaces/phong.h
-include/ray++/utils/vector_math.h
-include/ray++/utils/twister.h
-include/ray++/utils/math.h
-include/ray++/utils/noise.h
-include/ray++/utils/utils.h
-include/ray++/utils/colourmap.h
-include/ray++/utils/converter.h
-include/ray++/volumes/gas.h
-include/ray++/volumes/fog.h
-include/ray++/volumes/clear_glass.h
-include/ray++/volumes/gas2.h
-include/ray++/worlds/scene.h
-include/ray++/worlds/hmakers/hmaker.h
-include/ray++/worlds/hmakers/pov_hmaker.h
-include/ray++/worlds/hmakers/sort_entry.h
-lib/ray++.so
-@dirrm include/ray++/cameras
-@dirrm include/ray++/config
-@dirrm include/ray++/kernel
-@dirrm include/ray++/lights
-@dirrm include/ray++/objects
-@dirrm include/ray++/outputs
-@dirrm include/ray++/renderers
-@dirrm include/ray++/shapes
-@dirrm include/ray++/surfaces/pigments
-@dirrm include/ray++/surfaces
-@dirrm include/ray++/utils
-@dirrm include/ray++/volumes
-@dirrm include/ray++/worlds/hmakers
-@dirrm include/ray++/worlds
-@dirrm include/ray++