aboutsummaryrefslogtreecommitdiff
path: root/graphics/reactphysics3d
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-08-04 07:16:21 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-08-04 07:16:21 +0000
commitc790f961168150be25e3e1976cf1e45301c0a06e (patch)
tree2b8c6b8c11a0b929ae27e42a517407dc1a65023f /graphics/reactphysics3d
parent0adbee37b01a5d8778435227085149b30d70e648 (diff)
downloadports-c790f961168150be25e3e1976cf1e45301c0a06e.tar.gz
ports-c790f961168150be25e3e1976cf1e45301c0a06e.zip
Notes
Diffstat (limited to 'graphics/reactphysics3d')
-rw-r--r--graphics/reactphysics3d/Makefile20
-rw-r--r--graphics/reactphysics3d/distinfo3
-rw-r--r--graphics/reactphysics3d/pkg-descr22
-rw-r--r--graphics/reactphysics3d/pkg-plist89
4 files changed, 134 insertions, 0 deletions
diff --git a/graphics/reactphysics3d/Makefile b/graphics/reactphysics3d/Makefile
new file mode 100644
index 000000000000..c384a693aa5f
--- /dev/null
+++ b/graphics/reactphysics3d/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= reactphysics3d
+DISTVERSION= 0.7.0
+CATEGORIES= graphics
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C++ physics engine library in 3D
+
+LICENSE= ZLIB
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cmake:outsource
+USE_GITHUB= yes
+GH_ACCOUNT= DanielChappuis
+GH_TAGNAME= f86038aa31875daacc2d950be7b999c0d6a19986 # branch 'fix37'
+USE_LDCONFIG= yes
+CMAKE_ON= BUILD_SHARED_LIBS
+
+.include <bsd.port.mk>
diff --git a/graphics/reactphysics3d/distinfo b/graphics/reactphysics3d/distinfo
new file mode 100644
index 000000000000..6fc2119007dd
--- /dev/null
+++ b/graphics/reactphysics3d/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1533363447
+SHA256 (DanielChappuis-reactphysics3d-0.7.0-f86038aa31875daacc2d950be7b999c0d6a19986_GH0.tar.gz) = 7786e7ae19fa0594adda83719325791d732947bb9bde908f9de9a599e95b2afa
+SIZE (DanielChappuis-reactphysics3d-0.7.0-f86038aa31875daacc2d950be7b999c0d6a19986_GH0.tar.gz) = 8823041
diff --git a/graphics/reactphysics3d/pkg-descr b/graphics/reactphysics3d/pkg-descr
new file mode 100644
index 000000000000..ef8a58975252
--- /dev/null
+++ b/graphics/reactphysics3d/pkg-descr
@@ -0,0 +1,22 @@
+ReactPhysics3D is a C++ physics engine library that can be used in 3D
+simulations and games.
+
+ReactPhysics3D has the following features:
+* Rigid body dynamics
+* Discrete collision detection
+* Collision shapes (Sphere, Box, Capsule, Convex Mesh, Static Concave Mesh)
+* Multiple collision shapes per body
+* Broadphase collision detection (Dynamic AABB tree)
+* Narrowphase collision detection (SAT/GJK)
+* Collision response and friction (Sequential Impulses Solver)
+* Joints (Ball and Socket, Hinge, Slider, Fixed)
+* Collision filtering with categories
+* Ray casting
+* Sleeping technique for inactive bodies
+* Multi-platform (Windows, Linux, Mac OS X)
+* No external libraries (do not use STL containers)
+* Documentation (user manual and Doxygen API)
+* Testbed application with demos
+* Integrated Profiler
+
+WWW: https://www.reactphysics3d.com/
diff --git a/graphics/reactphysics3d/pkg-plist b/graphics/reactphysics3d/pkg-plist
new file mode 100644
index 000000000000..3e6e3fcd48a7
--- /dev/null
+++ b/graphics/reactphysics3d/pkg-plist
@@ -0,0 +1,89 @@
+include/reactphysics3d/AABB.h
+include/reactphysics3d/BallAndSocketJoint.h
+include/reactphysics3d/Body.h
+include/reactphysics3d/BoxShape.h
+include/reactphysics3d/BroadPhaseAlgorithm.h
+include/reactphysics3d/CapsuleShape.h
+include/reactphysics3d/CapsuleVsCapsuleAlgorithm.h
+include/reactphysics3d/CapsuleVsConvexPolyhedronAlgorithm.h
+include/reactphysics3d/CollisionBody.h
+include/reactphysics3d/CollisionCallback.h
+include/reactphysics3d/CollisionDetection.h
+include/reactphysics3d/CollisionDispatch.h
+include/reactphysics3d/CollisionShape.h
+include/reactphysics3d/CollisionWorld.h
+include/reactphysics3d/ConcaveMeshShape.h
+include/reactphysics3d/ConcaveShape.h
+include/reactphysics3d/ConstraintSolver.h
+include/reactphysics3d/ContactManifold.h
+include/reactphysics3d/ContactManifoldInfo.h
+include/reactphysics3d/ContactManifoldSet.h
+include/reactphysics3d/ContactPoint.h
+include/reactphysics3d/ContactPointInfo.h
+include/reactphysics3d/ContactSolver.h
+include/reactphysics3d/ConvexMeshShape.h
+include/reactphysics3d/ConvexPolyhedronShape.h
+include/reactphysics3d/ConvexPolyhedronVsConvexPolyhedronAlgorithm.h
+include/reactphysics3d/ConvexShape.h
+include/reactphysics3d/DefaultAllocator.h
+include/reactphysics3d/DefaultCollisionDispatch.h
+include/reactphysics3d/DynamicAABBTree.h
+include/reactphysics3d/DynamicsWorld.h
+include/reactphysics3d/EventListener.h
+include/reactphysics3d/FixedJoint.h
+include/reactphysics3d/GJKAlgorithm.h
+include/reactphysics3d/HalfEdgeStructure.h
+include/reactphysics3d/HeightFieldShape.h
+include/reactphysics3d/HingeJoint.h
+include/reactphysics3d/Island.h
+include/reactphysics3d/Joint.h
+include/reactphysics3d/LinkedList.h
+include/reactphysics3d/List.h
+include/reactphysics3d/Logger.h
+include/reactphysics3d/Map.h
+include/reactphysics3d/Material.h
+include/reactphysics3d/Matrix2x2.h
+include/reactphysics3d/Matrix3x3.h
+include/reactphysics3d/MemoryAllocator.h
+include/reactphysics3d/MemoryManager.h
+include/reactphysics3d/MiddlePhaseTriangleCallback.h
+include/reactphysics3d/NarrowPhaseAlgorithm.h
+include/reactphysics3d/NarrowPhaseInfo.h
+include/reactphysics3d/OverlapCallback.h
+include/reactphysics3d/OverlappingPair.h
+include/reactphysics3d/Pair.h
+include/reactphysics3d/PolygonVertexArray.h
+include/reactphysics3d/PolyhedronMesh.h
+include/reactphysics3d/PoolAllocator.h
+include/reactphysics3d/Profiler.h
+include/reactphysics3d/ProxyShape.h
+include/reactphysics3d/Quaternion.h
+include/reactphysics3d/Ray.h
+include/reactphysics3d/RaycastInfo.h
+include/reactphysics3d/RigidBody.h
+include/reactphysics3d/SATAlgorithm.h
+include/reactphysics3d/Set.h
+include/reactphysics3d/SingleFrameAllocator.h
+include/reactphysics3d/SliderJoint.h
+include/reactphysics3d/SphereShape.h
+include/reactphysics3d/SphereVsCapsuleAlgorithm.h
+include/reactphysics3d/SphereVsConvexPolyhedronAlgorithm.h
+include/reactphysics3d/SphereVsSphereAlgorithm.h
+include/reactphysics3d/Stack.h
+include/reactphysics3d/Timer.cpp
+include/reactphysics3d/Timer.h
+include/reactphysics3d/Transform.h
+include/reactphysics3d/TriangleMesh.h
+include/reactphysics3d/TriangleShape.h
+include/reactphysics3d/TriangleVertexArray.h
+include/reactphysics3d/Vector2.h
+include/reactphysics3d/Vector3.h
+include/reactphysics3d/VoronoiSimplex.h
+include/reactphysics3d/configuration.h
+include/reactphysics3d/decimal.h
+include/reactphysics3d/mathematics.h
+include/reactphysics3d/mathematics_functions.h
+include/reactphysics3d/reactphysics3d.h
+lib/libreactphysics3d.so
+lib/libreactphysics3d.so.0.7
+lib/libreactphysics3d.so.0.7.0