aboutsummaryrefslogtreecommitdiff
path: root/graphics/reallyslick
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 21:42:32 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 21:42:32 +0000
commit9010280b855a8f663dc0899ba61ab950e6b515da (patch)
treeade0e2be591e771231576c7a69bfc8a5cf0bc252 /graphics/reallyslick
parent06a3e062ca8655d412fd71bf237d2cbcb5d17726 (diff)
downloadports-9010280b855a8f663dc0899ba61ab950e6b515da.tar.gz
ports-9010280b855a8f663dc0899ba61ab950e6b515da.zip
Notes
Diffstat (limited to 'graphics/reallyslick')
-rw-r--r--graphics/reallyslick/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/graphics/reallyslick/Makefile b/graphics/reallyslick/Makefile
index 978345a3b3ef..0dbf51b52d8c 100644
--- a/graphics/reallyslick/Makefile
+++ b/graphics/reallyslick/Makefile
@@ -18,8 +18,9 @@ COMMENT= OpenGL screensaver collection
LIB_DEPENDS= MagickWand.5:${PORTSDIR}/graphics/ImageMagick \
GLC.0:${PORTSDIR}/graphics/quesoglc
-OPTIONS= FREEALUT "Enable freealut support" off \
- GLEW "Enable GLEW support" off
+OPTIONS_DEFINE= FREEALUT GLEW
+FREEALUT_DESC= Enable freealut support
+GLEW_DESC= Enable GLEW support
USE_BZIP2= yes
USE_GL= glut
@@ -36,18 +37,18 @@ MAN1= biof.1 busyspheres.1 colorfire.1 cyclone.1 drempels.1 \
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_FREEALUT)
+.if ${PORT_OPTIONS:MFREEALUT}
USE_OPENAL= alut
.else
CONFIGURE_ARGS+= --disable-sound
.endif
-.if defined(WITH_GLEW)
+.if ${PORT_OPTIONS:MGLEW}
USE_GL+= glew
.else
CONFIGURE_ENV+= ac_cv_header_GL_glew_h=no
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>