aboutsummaryrefslogtreecommitdiff
path: root/graphics/recoverjpeg/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2013-10-28 12:24:48 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2013-10-28 12:24:48 +0000
commit75abbcac3348705b12b2eecb07d7f357e19c9d77 (patch)
treea3cb9300ec0461c78a86c0f7d39559d002e603d5 /graphics/recoverjpeg/Makefile
parent8c93b1adb834d7ace728cf3db363f54bcba3f2be (diff)
downloadports-75abbcac3348705b12b2eecb07d7f357e19c9d77.tar.gz
ports-75abbcac3348705b12b2eecb07d7f357e19c9d77.zip
Notes
Diffstat (limited to 'graphics/recoverjpeg/Makefile')
-rw-r--r--graphics/recoverjpeg/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/graphics/recoverjpeg/Makefile b/graphics/recoverjpeg/Makefile
index 103860953453..ec04227a19e3 100644
--- a/graphics/recoverjpeg/Makefile
+++ b/graphics/recoverjpeg/Makefile
@@ -12,34 +12,32 @@ COMMENT= Recoverjpeg tries to recover JFIF (JPEG) pictures from a peripheral
LICENSE= GPLv2
GNU_CONFIGURE= yes
-MANCOMPRESSED= no
-PLIST_FILES= bin/recoverjpeg
MAN1= recoverjpeg.1
+PLIST_FILES= bin/recoverjpeg man/man1/recoverjpeg.1.gz
# recoverjpeg scripts require many dependencies
OPTIONS_DEFINE= SSCRIPTS
SSCRIPTS_DESC= Install sort-pictures script
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSSCRIPTS}
RUN_DEPENDS= exif:${PORTSDIR}/graphics/exif \
identify:${PORTSDIR}/graphics/ImageMagick
-PLIST_FILES+= bin/sort-pictures
+PLIST_FILES+= bin/sort-pictures man/man1/sort-pictures.1.gz
MAN1+= sort-pictures.1
.endif
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.if ${PORT_OPTIONS:MSSCRIPTS}
.for f in sort-pictures
- ${INSTALL_SCRIPT} ${WRKSRC}/${f} ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/bin
.endfor
.endif
.for f in ${MAN1}
- ${INSTALL_MAN} ${WRKSRC}/${f} ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/${f} ${STAGEDIR}${MANPREFIX}/man/man1
.endfor
.include <bsd.port.mk>