aboutsummaryrefslogtreecommitdiff
path: root/graphics/renrot/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-06-08 09:07:34 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-06-08 09:07:34 +0000
commit077a2ed61fbf3d68e8bfa9d9eb093997045275a0 (patch)
treeb99b9af1181267329662835330a97a91d4962e32 /graphics/renrot/Makefile
parent985ce60b1eb344d5a55e82f54d695a210257268d (diff)
downloadports-077a2ed61fbf3d68e8bfa9d9eb093997045275a0.tar.gz
ports-077a2ed61fbf3d68e8bfa9d9eb093997045275a0.zip
Notes
Diffstat (limited to 'graphics/renrot/Makefile')
-rw-r--r--graphics/renrot/Makefile23
1 files changed, 8 insertions, 15 deletions
diff --git a/graphics/renrot/Makefile b/graphics/renrot/Makefile
index b996cb21a076..8e02a0b37018 100644
--- a/graphics/renrot/Makefile
+++ b/graphics/renrot/Makefile
@@ -17,27 +17,20 @@ RUN_DEPENDS:= ${BUILD_DEPENDS} jpegtran:${PORTSDIR}/graphics/jpeg
USES= perl5
USE_PERL5= configure
-OPTIONS_DEFINE= IMAGEMAGICK DOCS
-IMAGEMAGICK_DESC= Image::Magick Perl module support
-
-MAN1= ${PORTNAME}.1
PORTDOCS= AUTHORS README README.russian ChangeLog NEWS TODO
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= IMAGEMAGICK DOCS
+IMAGEMAGICK_DESC= Image::Magick Perl module support
-.if ${PORT_OPTIONS:MIMAGEMAGICK}
-RUN_DEPENDS+= convert:${PORTSDIR}/graphics/ImageMagick
-.endif
+IMAGEMAGICK_RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
post-install:
- @${MKDIR} ${ETCDIR}
+ @${MKDIR} ${STAGEDIR}${ETCDIR}
.for conf in colors.conf copyright.tag renrot.conf tags.conf
- ${INSTALL_DATA} ${WRKSRC}/etc/${conf} ${ETCDIR}/${conf}.sample
+ ${INSTALL_DATA} ${WRKSRC}/etc/${conf} \
+ ${STAGEDIR}${ETCDIR}/${conf}.sample
.endfor
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>