aboutsummaryrefslogtreecommitdiff
path: root/graphics/rgbpaint/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-04-03 20:58:29 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-04-03 20:58:29 +0000
commitad2c8f78e11c0c9605ae0ddf58e709d35e4da6be (patch)
tree5ed8e5f16aa0e7b88f65f4152afbbd1491776648 /graphics/rgbpaint/Makefile
parent00993fd72194161dd220a5689316e0998585a7bd (diff)
Add port graphics/rgbpaint:
rgbPaint is a very basic GTK+2.6 (or later) based program designed for editing pixel based images. It is a fork of mtPaint 3.09. It can only edit and save RGB images to PNG, JPEG, or ICO files. It can read PNG, JPEG, TIFF, GIF, ICO, files and possibly others like TGA, PCX, and SVGi if they are installed with your version of GTK+2. WWW: http://mtpaint.sourceforge.net/ Author: Dmitry Groshev <wjaguar@users.sourceforge.net>
Notes
Notes: svn path=/head/; revision=189125
Diffstat (limited to 'graphics/rgbpaint/Makefile')
-rw-r--r--graphics/rgbpaint/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/graphics/rgbpaint/Makefile b/graphics/rgbpaint/Makefile
new file mode 100644
index 000000000000..6f29d3bdfa82
--- /dev/null
+++ b/graphics/rgbpaint/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: rgbpaint
+# Date created: 4 April 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rgbpaint
+PORTVERSION= 0.8.5
+CATEGORIES= graphics
+MASTER_SITES= SF/mtpaint
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Very basic painting program
+
+USE_GETTEXT= yes
+USE_BZIP2= yes
+USE_GNOME= gtk20
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX} --mandir=${MAN1PREFIX}/man/man1 \
+ --locale=${PREFIX}/share/locale cflags slow intl man
+MAN1= ${PORTNAME}.1
+MANCOMPRESSED= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e '/if \[/s|==|=|g' ${WRKSRC}/configure
+
+.include <bsd.port.mk>