aboutsummaryrefslogtreecommitdiff
path: root/graphics/rgbpaint
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-04-03 20:58:29 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-04-03 20:58:29 +0000
commitad2c8f78e11c0c9605ae0ddf58e709d35e4da6be (patch)
tree5ed8e5f16aa0e7b88f65f4152afbbd1491776648 /graphics/rgbpaint
parent00993fd72194161dd220a5689316e0998585a7bd (diff)
downloadports-ad2c8f78e11c0c9605ae0ddf58e709d35e4da6be.tar.gz
ports-ad2c8f78e11c0c9605ae0ddf58e709d35e4da6be.zip
Notes
Diffstat (limited to 'graphics/rgbpaint')
-rw-r--r--graphics/rgbpaint/Makefile28
-rw-r--r--graphics/rgbpaint/distinfo3
-rw-r--r--graphics/rgbpaint/pkg-descr8
-rw-r--r--graphics/rgbpaint/pkg-plist20
4 files changed, 59 insertions, 0 deletions
diff --git a/graphics/rgbpaint/Makefile b/graphics/rgbpaint/Makefile
new file mode 100644
index 000000000000..6f29d3bdfa82
--- /dev/null
+++ b/graphics/rgbpaint/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: rgbpaint
+# Date created: 4 April 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rgbpaint
+PORTVERSION= 0.8.5
+CATEGORIES= graphics
+MASTER_SITES= SF/mtpaint
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Very basic painting program
+
+USE_GETTEXT= yes
+USE_BZIP2= yes
+USE_GNOME= gtk20
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix=${PREFIX} --mandir=${MAN1PREFIX}/man/man1 \
+ --locale=${PREFIX}/share/locale cflags slow intl man
+MAN1= ${PORTNAME}.1
+MANCOMPRESSED= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e '/if \[/s|==|=|g' ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/graphics/rgbpaint/distinfo b/graphics/rgbpaint/distinfo
new file mode 100644
index 000000000000..a03b9f7a4fa9
--- /dev/null
+++ b/graphics/rgbpaint/distinfo
@@ -0,0 +1,3 @@
+MD5 (rgbpaint-0.8.5.tar.bz2) = 0c3b186e25e08431a5ab59d288bb9d5f
+SHA256 (rgbpaint-0.8.5.tar.bz2) = 46761570a6e2b477d0e1c7d40d9dace2fac5a19a40de3d6534e191a8e2702a4e
+SIZE (rgbpaint-0.8.5.tar.bz2) = 73715
diff --git a/graphics/rgbpaint/pkg-descr b/graphics/rgbpaint/pkg-descr
new file mode 100644
index 000000000000..1c917e33e3a8
--- /dev/null
+++ b/graphics/rgbpaint/pkg-descr
@@ -0,0 +1,8 @@
+rgbPaint is a very basic GTK+2.6 (or later) based program designed for
+editing pixel based images. It is a fork of mtPaint 3.09. It can only
+edit and save RGB images to PNG, JPEG, or ICO files. It can read PNG,
+JPEG, TIFF, GIF, ICO, files and possibly others like TGA, PCX, and SVGi
+if they are installed with your version of GTK+2.
+
+WWW: http://mtpaint.sourceforge.net/
+Author: Dmitry Groshev <wjaguar@users.sourceforge.net>
diff --git a/graphics/rgbpaint/pkg-plist b/graphics/rgbpaint/pkg-plist
new file mode 100644
index 000000000000..cbe914c554d4
--- /dev/null
+++ b/graphics/rgbpaint/pkg-plist
@@ -0,0 +1,20 @@
+bin/rgbpaint
+share/locale/cs/LC_MESSAGES/rgbpaint.mo
+share/locale/de_DE/LC_MESSAGES/rgbpaint.mo
+share/locale/es/LC_MESSAGES/rgbpaint.mo
+share/locale/fr/LC_MESSAGES/rgbpaint.mo
+share/locale/pl/LC_MESSAGES/rgbpaint.mo
+share/locale/pt/LC_MESSAGES/rgbpaint.mo
+share/locale/pt_BR/LC_MESSAGES/rgbpaint.mo
+share/locale/tr/LC_MESSAGES/rgbpaint.mo
+share/locale/zh_TW/LC_MESSAGES/rgbpaint.mo
+@dirrmtry share/locale/cs/LC_MESSAGES
+@dirrmtry share/locale/cs
+@dirrmtry share/locale/de_DE/LC_MESSAGES
+@dirrmtry share/locale/de_DE
+@dirrmtry share/locale/pl/LC_MESSAGES
+@dirrmtry share/locale/pl
+@dirrmtry share/locale/pt/LC_MESSAGES
+@dirrmtry share/locale/pt
+@dirrmtry share/locale/zh_TW/LC_MESSAGES
+@dirrmtry share/locale/zh_TW