aboutsummaryrefslogtreecommitdiff
path: root/graphics/robot
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-12-28 16:09:24 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-12-28 16:09:24 +0000
commite396b31ad13bfddafd685d08ca02f076a2f82170 (patch)
tree48d0da8c1c32b1f750f6266fa55a7ec85969896c /graphics/robot
parentd23d6ca3aafb032e45bc22327bd6459baa7e1ff0 (diff)
downloadports-e396b31ad13bfddafd685d08ca02f076a2f82170.tar.gz
ports-e396b31ad13bfddafd685d08ca02f076a2f82170.zip
Notes
Diffstat (limited to 'graphics/robot')
-rw-r--r--graphics/robot/Makefile4
-rw-r--r--graphics/robot/distinfo6
-rw-r--r--graphics/robot/files/patch-ARK+Makefile17
-rw-r--r--graphics/robot/files/patch-Robot+Makefile46
-rw-r--r--graphics/robot/files/patch-Robot+main.c32
5 files changed, 46 insertions, 59 deletions
diff --git a/graphics/robot/Makefile b/graphics/robot/Makefile
index 259684672d80..171f9cb11716 100644
--- a/graphics/robot/Makefile
+++ b/graphics/robot/Makefile
@@ -7,7 +7,7 @@
PORTNAME= robot
PORTVERSION= 4.93.89
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics
MASTER_SITES= ftp://lheaftp.gsfc.nasa.gov/pub/corbet/robot/
DISTNAME= robot-beta
@@ -18,8 +18,6 @@ COMMENT= Graph plotting and data analysis program using OpenLook
BUILD_DEPENDS= fsplit:${PORTSDIR}/devel/fortran-utils
LIB_DEPENDS= xview.3:${PORTSDIR}/x11-toolkits/xview
-BROKEN= Size mismatch
-
USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
diff --git a/graphics/robot/distinfo b/graphics/robot/distinfo
index 4c5969ed8d80..82d8ea8cf0f7 100644
--- a/graphics/robot/distinfo
+++ b/graphics/robot/distinfo
@@ -1,3 +1,3 @@
-MD5 (robot-beta.tar.gz) = ded1147f41e643c792d4b1d792737571
-SHA256 (robot-beta.tar.gz) = 44dca25e78608d3fd84aa1127986b40aa98eccaccef3b0d28dcbc004c3285486
-SIZE (robot-beta.tar.gz) = 613241
+MD5 (robot-beta.tar.gz) = d477d77c5ba2fe350e12cb1591a41f5a
+SHA256 (robot-beta.tar.gz) = 3b87d56cda7d117bc216a4fdef44819e335d43a5b318523901c8c40a84fb3e00
+SIZE (robot-beta.tar.gz) = 619415
diff --git a/graphics/robot/files/patch-ARK+Makefile b/graphics/robot/files/patch-ARK+Makefile
index f96c25506e70..8bb0b5ddaaa0 100644
--- a/graphics/robot/files/patch-ARK+Makefile
+++ b/graphics/robot/files/patch-ARK+Makefile
@@ -1,21 +1,22 @@
---- ARK/Makefile.orig Sat Oct 11 14:58:54 2003
-+++ ARK/Makefile Sat Oct 11 15:00:04 2003
-@@ -1,12 +1,12 @@
+--- ARK/Makefile.orig Tue May 3 17:14:51 2005
++++ ARK/Makefile Wed Dec 28 16:56:58 2005
+@@ -1,13 +1,13 @@
#CC = gcc -ansi
-CC = gcc
-+#CC ?= cc
++#CC = gcc
#CC = cc
-FC = f77
-+#FC ?= f77
++#FC = f77
#FC = g77
INCLUDE = ${OPENWINHOME}/include
#CFLAGS = -Wall
--CFLAGS = -O
-+#CFLAGS += -O
- #CFLAGS = -g
+ #CFLAGS = -O
+-CFLAGS = -g -Wall
++#CFLAGS = -g -Wall
+ OBJECTS = libark.a
@@ -17,7 +17,7 @@
arkcplot.o: arkcplot.c kana.h kana2.h
$(CC) -c $(CFLAGS) arkcplot.c -I$(INCLUDE) $(OS) -DLPR=\"$(LPR)\"
diff --git a/graphics/robot/files/patch-Robot+Makefile b/graphics/robot/files/patch-Robot+Makefile
index 6639d720a2af..b38b35feb84e 100644
--- a/graphics/robot/files/patch-Robot+Makefile
+++ b/graphics/robot/files/patch-Robot+Makefile
@@ -1,50 +1,38 @@
---- Robot/Makefile.orig Wed Apr 23 17:04:37 2003
-+++ Robot/Makefile Sat Oct 11 15:31:37 2003
-@@ -7,7 +7,7 @@
-
- ARRAYSIZE = 64000
-
--# Where will Robot try and look for help about itself with (e.g.) netscape?
-+# Where will Robot try and look for help about itself with (e.g.) mozilla?
- WEB_HELP = http://www.robotx.cx/
-
- # and give option to use a different browser if really wanted
-@@ -15,28 +15,28 @@
+--- Robot/Makefile.orig Tue May 3 17:14:51 2005
++++ Robot/Makefile Wed Dec 28 16:58:22 2005
+@@ -15,7 +15,7 @@
# define system utilities - i.e. mail and print
-MAILER = /bin/mail
+MAILER = /usr/bin/mail
# Either lpr, lp, or enscript/genscript may be used to print
--#LPR = /usr/ucb/lpr
-+#LPR = /usr/bin/lpr
+ #LPR = /usr/ucb/lpr
#LPR = /bin/lp
- LPR = lpr
+@@ -23,18 +23,18 @@
# installation directory - this is used both if a "make install" is
# done and also used to add path to robot at top of log files
-INSTDIR = $(HOME)/bin/
-+INSTDIR = ${PREFIX}/bin/
++INSTDIR = $(PREFIX)/bin/
#INSTDIR = /usr/local/bin
# define compilers
#CC = cc
-CC = gcc
-+CC ?= cc
++CC ?= gcc
#FC = g77
-FC = f77
+FC ?= f77
# define compile options here if required,
# e.g. debug
- # CFLAGS = -g
+- CFLAGS = -g -Wall
++# CFLAGS = -g -Wall
# or optimize (if you have enough swap space)
-- CFLAGS = -O
-+CFLAGS += -O
- # or nothing at all
- # CFLAGS =
-
-@@ -45,7 +45,6 @@
+ # CFLAGS = -O
+ # Turn warnings on
+@@ -47,7 +47,6 @@
# Check array boundaries
# FFLAGS = -C
@@ -52,7 +40,7 @@
# specify here the directory where the openwindow include
# files are kept
# INCLUDE = /usr/local/openwin/include
-@@ -63,15 +62,15 @@
+@@ -65,15 +64,15 @@
#F77LIB = -lF77
#X library - may need to edit if location different
@@ -71,7 +59,7 @@
# This specifies the location of the graphics routines in
-@@ -79,7 +78,7 @@
+@@ -81,7 +80,7 @@
ARKDIR = ../ARK/
ARKLIB = $(ARKDIR)libark.a
# place to put the robot.info file
@@ -80,7 +68,7 @@
OBJS = robot.o subroutines.o subroutines2.o subroutines3.o \
user.o main.o rfitsf.o rfitsc.o fits3d.o york.o classify.o \
-@@ -109,11 +108,11 @@
+@@ -111,11 +110,11 @@
"OLLIBS=$(OPENWINHOME)/lib/libxview.so $(OPENWINHOME)/lib/libolgx.so"
FITSLIB:
@@ -95,7 +83,7 @@
subroutines.o: subroutines.f robcom fitcom
$(FC) -c $(CFLAGS) $(FFLAGS) subroutines.f
subroutines2.o: subroutines2.f robcom msizcom fitcom
-@@ -121,7 +120,7 @@
+@@ -123,7 +122,7 @@
subroutines3.o: subroutines3.f robcom msizcom
$(FC) -c $(CFLAGS) $(FFLAGS) subroutines3.f
nr.o: nr.f robcom
@@ -104,7 +92,7 @@
main.o: main.c robot.h patchlevel.h
$(CC) -c $(CFLAGS) main.c -I$(INCLUDE) $(LANGUAGE) $(OS) -DARRAYSIZE=$(ARRAYSIZE) -DINSTDIR=\"$(INSTDIR)\" -DWEB_HELP=\"$(WEB_HELP)\"
colors.o: colors.c
-@@ -155,15 +154,15 @@
+@@ -157,15 +156,15 @@
math.o: math.c
$(CC) -c $(CFLAGS) math.c
user.o: user.f
diff --git a/graphics/robot/files/patch-Robot+main.c b/graphics/robot/files/patch-Robot+main.c
index 52638a9c2962..1707e5ea22b0 100644
--- a/graphics/robot/files/patch-Robot+main.c
+++ b/graphics/robot/files/patch-Robot+main.c
@@ -1,6 +1,6 @@
---- Robot/main.c.orig Sat Oct 11 13:14:19 2003
-+++ Robot/main.c Sat Oct 11 13:22:51 2003
-@@ -539,20 +539,19 @@
+--- Robot/main.c.orig Tue May 3 17:14:51 2005
++++ Robot/main.c Wed Dec 28 17:02:15 2005
+@@ -561,19 +561,19 @@
|| streq(argv[i], "--help") ){
printf("Robot version %-1.2f patch %d\n\n",
VERSION, PATCHLEVEL);
@@ -14,22 +14,22 @@
--v (print version number and quit)\n\
--help/-h (prints this information and quits)\n\
-(optional command file name)\n\n\
-+ printf("robot (generic-tool-options)\n");
-+printf("-arraysize [size of arrays, default is %d]\n");
-+printf("-plotscale [scale factor]\n");
-+printf("-portrait\n");
-+printf("-landscape (default)\n");
-+printf("-notol (not Open-look - adds some extra quit buttons)\n");
-+printf("-stdin (reads commands from standard input instead of GUI)\n");
-+printf("-v (print version number and quit)\n");
-+printf("-help/-h (prints this information and quits)\n");
-+printf("(optional command file name)\n\n");
-
-For more information see help available in the program under\n\
-the \"About\" option or visit:\n\
-%s\n", msize, WEB_HELP);
-+printf("For more information see help available in the program under\n");
-+printf("the \"About\" option or visit:\n\%s\n", msize, WEB_HELP);
++ printf("robot (generic-tool-options)\n");
++ printf("-arraysize [size of arrays, default is %d]\n");
++ printf("-plotscale [scale factor]\n");
++ printf("-portrait\n");
++ printf("-landscape (default)\n");
++ printf("-notol (not Open-look - adds some extra quit buttons)\n");
++ printf("-stdin (reads commands from standard input instead of GUI)\n");
++ printf("-v (print version number and quit)\n");
++ printf("-help/-h (prints this information and quits)\n");
++ printf("(optional command file name)\n\n");
++ printf("For more information see help available in the program under\n");
++ printf("the \"About\" option or visit:\n");
++ printf("%s\n", msize, WEB_HELP);
fstop_();
}