aboutsummaryrefslogtreecommitdiff
path: root/graphics/ruby-gd/Makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-08-18 16:15:10 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-08-18 16:15:10 +0000
commitefb928619b234d49b326a13f59a6e2ee354bf902 (patch)
treec62bd82140831e81442480b9cefc699e0c08f08d /graphics/ruby-gd/Makefile
parentdfc14c855f8ec76c9bd42bc90e325a160cc5d6cf (diff)
o Main modification
graphics/gd(based on 1.8.4) -> graphics/gd1 graphics/gd2(based on 2.0.15) -> graphics/gd graphics/p5-GD(based on 1.41) -> graphics/p5-GD1 graphics/p5-GD2(based on 2.07) -> graphics/p5-GD japanese/gd -> japanese/gd1 japanese/gd2 -> japanese/gd o Include some feature WITH_XPM(w/, w/o WITHOUT_X11) o Chase this modification o Fix build error [1] PR: ports/54540 Submitted by: Ports Fury Approved by: maintainer (blanket) Reported by: bento via kris [1]
Notes
Notes: svn path=/head/; revision=87214
Diffstat (limited to 'graphics/ruby-gd/Makefile')
-rw-r--r--graphics/ruby-gd/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/graphics/ruby-gd/Makefile b/graphics/ruby-gd/Makefile
index 6201076116e2..ea791d55c59a 100644
--- a/graphics/ruby-gd/Makefile
+++ b/graphics/ruby-gd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= GD
PORTVERSION= 0.7.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics ruby
MASTER_SITES= http://www.acc.ne.jp/~tam/GD/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -30,13 +30,13 @@ CONFIGURE_ARGS= --with-gd-lib="${LOCALBASE}/lib" \
--with-freetype
INSTALL_TARGET= site-install
-.if defined(WITH_GD2)
+.if defined(WITH_GD1)
+CONFIGURE_ARGS+= --with-gd-include="${LOCALBASE}/include/gd"
+LIB_DEPENDS+= gd1.2:${PORTSDIR}/graphics/gd1
+.else
CONFIGURE_ARGS+= ----enable-gd2_0 \
- --with-gd-include="${LOCALBASE}/include"
+ --with-gd-include="${LOCALBASE}/include"
LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd
-.else
-CONFIGURE_ARGS+= --with-gd-include="${LOCALBASE}/include/gd"
-LIB_DEPENDS+= gd1.2:${PORTSDIR}/graphics/gd
.endif
.include <bsd.port.pre.mk>
@@ -70,10 +70,10 @@ DOCS_JA= readme.ja \
post-patch:
${RUBY} -i -pe 'sub %r:/win98/windows/FONTS:, "${X11BASE}/lib/X11/fonts/TrueType"' ${WRKSRC}/sample/gdtestttf.rb
-.if defined(WITH_GD2)
- ${RUBY} -i -pe 'sub %r:%%GD%%:, "gd"' ${WRKSRC}/extconf.rb
-.else
+.if defined(WITH_GD1)
${RUBY} -i -pe 'sub %r:%%GD%%:, "gd1"' ${WRKSRC}/extconf.rb
+.else
+ ${RUBY} -i -pe 'sub %r:%%GD%%:, "gd"' ${WRKSRC}/extconf.rb
.endif
post-install: