aboutsummaryrefslogtreecommitdiff
path: root/graphics/ruby-libart2
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2002-09-01 13:50:37 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2002-09-01 13:50:37 +0000
commitaba02ba09211fd8d6c8912cc12ff9eea522308af (patch)
tree2c9c0690260b4accfbe2646312335f6ca791ca27 /graphics/ruby-libart2
parent18575f34dcd5d78cb28973ef9882fb23a5b9bdfb (diff)
downloadports-aba02ba09211fd8d6c8912cc12ff9eea522308af.tar.gz
ports-aba02ba09211fd8d6c8912cc12ff9eea522308af.zip
Notes
Diffstat (limited to 'graphics/ruby-libart2')
-rw-r--r--graphics/ruby-libart2/Makefile41
-rw-r--r--graphics/ruby-libart2/pkg-comment1
-rw-r--r--graphics/ruby-libart2/pkg-descr4
-rw-r--r--graphics/ruby-libart2/pkg-plist6
4 files changed, 52 insertions, 0 deletions
diff --git a/graphics/ruby-libart2/Makefile b/graphics/ruby-libart2/Makefile
new file mode 100644
index 000000000000..e6bd2d5d3917
--- /dev/null
+++ b/graphics/ruby-libart2/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: ruby-libart
+# Date created: 1 September 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libart
+PORTVERSION= ${RUBY_GNOME_PORTVERSION}
+CATEGORIES= graphics ruby
+MASTER_SITES= ${RUBY_GNOME_MASTER_SITES}
+MASTER_SITE_SUBDIR= ${RUBY_GNOME_MASTER_SITE_SUBDIR}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${RUBY_GNOME_DISTNAME}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+LIB_DEPENDS= art_lgpl.5:${PORTSDIR}/graphics/libart
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+.include "${.CURDIR}/../../x11/ruby-gnome/Makefile.common"
+
+WRKSRC= ${RUBY_GNOME_WRKSRC}/${PORTNAME}
+INSTALL_TARGET= site-install
+
+DOCS_EN= ChangeLog README
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${CP} -R ${WRKSRC}/sample/* ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/ruby-libart2/pkg-comment b/graphics/ruby-libart2/pkg-comment
new file mode 100644
index 000000000000..3274af612f95
--- /dev/null
+++ b/graphics/ruby-libart2/pkg-comment
@@ -0,0 +1 @@
+Ruby binding for libart
diff --git a/graphics/ruby-libart2/pkg-descr b/graphics/ruby-libart2/pkg-descr
new file mode 100644
index 000000000000..620974f6e7b4
--- /dev/null
+++ b/graphics/ruby-libart2/pkg-descr
@@ -0,0 +1,4 @@
+Ruby/libart is a Ruby binding for libart.
+
+Author: KUBO Takehiro <kubo@jiubao.org>, Ruby-GNOME Project Team
+WWW: http://ruby-gnome.sourceforge.net/
diff --git a/graphics/ruby-libart2/pkg-plist b/graphics/ruby-libart2/pkg-plist
new file mode 100644
index 000000000000..0b1c6e90f1d2
--- /dev/null
+++ b/graphics/ruby-libart2/pkg-plist
@@ -0,0 +1,6 @@
+%%RUBY_SITEARCHLIBDIR%%/libart.so
+%%PORTDOCS%%%%RUBY_EXAMPLESDIR%%/libart/gnome-canvas.rb
+%%PORTDOCS%%@dirrm %%RUBY_EXAMPLESDIR%%/libart
+%%PORTDOCS%%%%RUBY_DOCDIR%%/libart/ChangeLog
+%%PORTDOCS%%%%RUBY_DOCDIR%%/libart/README
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/libart