aboutsummaryrefslogtreecommitdiff
path: root/graphics/ruby-opengl/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-04-27 19:30:49 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-04-27 19:30:49 +0000
commit79981ed203807c5c2ac6fb6d7133bbbb434a1b7c (patch)
treea72bc69224f4f47abdd2d8a54e15566d2e3d8cf9 /graphics/ruby-opengl/Makefile
parenta585574c6cea24cb84901959c091bb9f9982535c (diff)
downloadports-79981ed203807c5c2ac6fb6d7133bbbb434a1b7c.tar.gz
ports-79981ed203807c5c2ac6fb6d7133bbbb434a1b7c.zip
Notes
Diffstat (limited to 'graphics/ruby-opengl/Makefile')
-rw-r--r--graphics/ruby-opengl/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/graphics/ruby-opengl/Makefile b/graphics/ruby-opengl/Makefile
index 0bc68b2065ed..881c0eb493a9 100644
--- a/graphics/ruby-opengl/Makefile
+++ b/graphics/ruby-opengl/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= opengl
-PORTVERSION= 0.31
-PORTREVISION= 1
+PORTVERSION= 0.32
CATEGORIES= graphics ruby
-MASTER_SITES= http://www2.giganet.net/~yoshi/
+MASTER_SITES= http://www.ruby-lang.org/~knu/
+#MASTER_SITES= http://www2.giganet.net/~yoshi/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
-DISTNAME= rbogl
+DISTNAME= rbogl-${PORTVERSION}
EXTRACT_SUFX= .tgz
DIST_SUBDIR= ruby
@@ -22,17 +22,17 @@ USE_RUBY_EXTCONF= yes
USE_MESA= yes
-WRKSRC= ${WRKDIR}/oglmodule
+WRKSRC= ${WRKDIR}/${PORTNAME}
CONFIGURE_ARGS= --with-ruby-dir="${LOCALBASE}" --with-x11-dir="${X11BASE}"
INSTALL_TARGET= site-install
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_EXAMPLESDIR}/opengl
- ${INSTALL_DATA} ${WRKSRC}/sample/*.rb ${RUBY_EXAMPLESDIR}/opengl/
- ${MKDIR} ${RUBY_DOCDIR}/opengl/ja
- ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${RUBY_DOCDIR}/opengl/
- ${INSTALL_DATA} ${WRKSRC}/README.EUC ${RUBY_DOCDIR}/opengl/ja/
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/sample/*.rb ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}/ja
+ ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${RUBY_DOCDIR}/${PORTNAME}/
+ ${INSTALL_DATA} ${WRKSRC}/README.EUC ${RUBY_DOCDIR}/${PORTNAME}/ja/
.endif
.include <bsd.port.mk>