aboutsummaryrefslogtreecommitdiff
path: root/graphics/ruby-pgplot/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-06-27 02:06:57 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-06-27 02:06:57 +0000
commitaab2047b998be0149abacf23900c6183dad6b90c (patch)
treecd42bbe3d6093230c3146f927eb32e5fabb6657a /graphics/ruby-pgplot/Makefile
parentefc83389b982ecd2ba16add82354d1d4c057ca97 (diff)
Notes
Diffstat (limited to 'graphics/ruby-pgplot/Makefile')
-rw-r--r--graphics/ruby-pgplot/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/graphics/ruby-pgplot/Makefile b/graphics/ruby-pgplot/Makefile
new file mode 100644
index 000000000000..9a0680cf84b7
--- /dev/null
+++ b/graphics/ruby-pgplot/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: Ruby/PGPLOT
+# Date created: 26 June 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pgplot
+PORTVERSION= 0.1.1
+CATEGORIES= graphics ruby
+MASTER_SITES= http://www.ir.isas.ac.jp/~masa/ruby/dist/
+MASTER_SITE_SUBDIR= knu
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= rb_${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+LIB_DEPENDS= pgplot.5:${PORTSDIR}/graphics/pgplot
+RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/narray.so:${PORTSDIR}/math/ruby-narray
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+CONFIGURE_ARGS= --with-x11-dir="${X11BASE}"
+INSTALL_TARGET= site-install
+
+DOCS_EN= FuncUsage README.en
+DOCS_JA= README.jp
+EXAMPLES_EN= pgdemo*.rb test/*.rb
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+.for f in ${EXAMPLES_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+.endfor
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}/ja
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.for f in ${DOCS_JA}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/ja/
+.endfor
+.endif
+
+.include <bsd.port.mk>