aboutsummaryrefslogtreecommitdiff
path: root/graphics/ruby-qt2gl
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-03-12 18:57:25 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-03-12 18:57:25 +0000
commit1f10416736ceac3b645d0b84f9fcdc94e82905c3 (patch)
treed3278878767140b56b246164499c802403088ef6 /graphics/ruby-qt2gl
parent0352bcfa983fae6b4284642dfb17605d176916f4 (diff)
downloadports-1f10416736ceac3b645d0b84f9fcdc94e82905c3.tar.gz
ports-1f10416736ceac3b645d0b84f9fcdc94e82905c3.zip
Notes
Diffstat (limited to 'graphics/ruby-qt2gl')
-rw-r--r--graphics/ruby-qt2gl/Makefile22
-rw-r--r--graphics/ruby-qt2gl/files/patch-extconf.rb11
2 files changed, 10 insertions, 23 deletions
diff --git a/graphics/ruby-qt2gl/Makefile b/graphics/ruby-qt2gl/Makefile
index 10b89652c16c..ece13250f31e 100644
--- a/graphics/ruby-qt2gl/Makefile
+++ b/graphics/ruby-qt2gl/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= qt2gl
-PORTVERSION= 0.11
+PORTVERSION= ${RUBY_QT2_PORTVERSION}
CATEGORIES= graphics x11-toolkits ruby
-MASTER_SITES= http://sfns.u-shizuoka-ken.ac.jp/geneng/horie_hp/ruby/
+MASTER_SITES= ${RUBY_QT2_MASTER_SITES}
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
-DISTNAME= ruby-qt2-${PORTVERSION}
+DISTNAME= ${RUBY_QT2_DISTNAME}
DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
@@ -19,17 +19,15 @@ BUILD_DEPENDS= ${RUBY_SITEARCHLIBDIR}/qt2.so:${RUBY_QT2_PORTDIR}
RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/qt2.so:${RUBY_QT2_PORTDIR} \
${RUBY_SITEARCHLIBDIR}/opengl.so:${PORTSDIR}/graphics/ruby-opengl
-RUBY_QT2_PORTDIR= ${PORTSDIR}/x11-toolkits/ruby-qt2
-
-MD5_FILE= ${RUBY_QT2_PORTDIR}/distinfo
-
USE_MESA= yes
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
USE_GMAKE= yes
-WRKSRC= ${WRKDIR}/qt2/modules/opengl
+.include "${.CURDIR}/../../x11-toolkits/ruby-qt2/Makefile.common"
+
+WRKSRC= ${RUBY_QT2_WRKSRC}/modules/opengl
CONFIGURE_ARGS= --with-qt2-include=${X11BASE}/include/qt2 \
--with-qt2-lib=${X11BASE}/lib \
--with-qt2=qt2 \
@@ -42,10 +40,10 @@ post-extract:
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_EXAMPLESDIR}/qt2gl
- ${CP} -R ${WRKSRC}/examples/* ${RUBY_EXAMPLESDIR}/qt2gl/
- ${MKDIR} ${RUBY_DOCDIR}/qt2gl
- ${INSTALL_DATA} ${WRKSRC}/README ${RUBY_DOCDIR}/qt2gl/
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${CP} -R ${WRKSRC}/examples/* ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/README ${RUBY_DOCDIR}/${PORTNAME}/
.endif
.include <bsd.port.mk>
diff --git a/graphics/ruby-qt2gl/files/patch-extconf.rb b/graphics/ruby-qt2gl/files/patch-extconf.rb
deleted file mode 100644
index 66a127f2a652..000000000000
--- a/graphics/ruby-qt2gl/files/patch-extconf.rb
+++ /dev/null
@@ -1,11 +0,0 @@
---- extconf.rb.orig Mon Jan 15 13:37:15 2001
-+++ extconf.rb Wed Feb 7 14:53:24 2001
-@@ -20,7 +20,7 @@
-
- $CFLAGS += ' -I. -O -w '
-
--if have_header('qapplication.h') and have_header('qgl.h') and have_library('qt','qGLVersion__Fv')
-+if have_header('qapplication.h') and have_header('qgl.h') and have_library(qt2,'qGLVersion__Fv')
- create_makefile('qt2gl')
- else
- print "You do not seem to have qt(+qgl) library. Plrease check qt or extconf.rb.\n"