aboutsummaryrefslogtreecommitdiff
path: root/graphics/ruby-redact/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-04-08 23:43:20 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-04-08 23:43:20 +0000
commit34044921bd39672f12bd9084c2cbac4699b1b3e6 (patch)
tree6fc6c92f16c03ade8cd88ad365e0ef52c0d4c6ec /graphics/ruby-redact/Makefile
parent09de6e4786fa9af011418a88ae80cb7e78ee661e (diff)
downloadports-34044921bd39672f12bd9084c2cbac4699b1b3e6.tar.gz
ports-34044921bd39672f12bd9084c2cbac4699b1b3e6.zip
Notes
Diffstat (limited to 'graphics/ruby-redact/Makefile')
-rw-r--r--graphics/ruby-redact/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/graphics/ruby-redact/Makefile b/graphics/ruby-redact/Makefile
new file mode 100644
index 000000000000..6d0f14273406
--- /dev/null
+++ b/graphics/ruby-redact/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: redact
+# Date created: 06 Apr 2006
+# Whom: Alexander Botero-Lowry <alex@foxybanana.com>
+#
+# $FreeBSD$
+
+PORTNAME= redact
+PORTVERSION= 0.1.5
+CATEGORIES= graphics ruby
+MASTER_SITES= ftp://ftp.code-monkey.de/pub/redact/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+
+MAINTAINER= alex@foxybanana.com
+COMMENT= An edje compiler written in ruby
+
+BUILD_DEPENDS= ${RUBY_SITEARCHLIBDIR}/imlib2.so:${PORTSDIR}/graphics/ruby-imlib2 \
+ ${RUBY_SITELIBDIR}/eet.rb:${PORTSDIR}/devel/ruby-eet \
+ ${LOCALBASE}/bin/rake:${PORTSDIR}/devel/rubygem-rake
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_RUBY= yes
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ @cd ${WRKSRC} && ${LOCALBASE}/bin/rake PREFIX=${PREFIX}/ install
+
+.include <bsd.port.post.mk>