aboutsummaryrefslogtreecommitdiff
path: root/graphics/ruby-rmagick/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2003-06-26 04:16:01 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2003-06-26 04:16:01 +0000
commit84e37fa0231575ef3780f5e12dafc701273766b3 (patch)
treea91ec4c74f28b9ee502a4a9bad825b8d39014500 /graphics/ruby-rmagick/Makefile
parent703bbb782630b13db9404cf2c4e9907b02370792 (diff)
downloadports-84e37fa0231575ef3780f5e12dafc701273766b3.tar.gz
ports-84e37fa0231575ef3780f5e12dafc701273766b3.zip
Notes
Diffstat (limited to 'graphics/ruby-rmagick/Makefile')
-rw-r--r--graphics/ruby-rmagick/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/graphics/ruby-rmagick/Makefile b/graphics/ruby-rmagick/Makefile
index a4427a7113bb..32cff77384e4 100644
--- a/graphics/ruby-rmagick/Makefile
+++ b/graphics/ruby-rmagick/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= rmagick
-PORTVERSION= 1.1.0
+PORTVERSION= 1.2.2
CATEGORIES= graphics ruby
MASTER_SITES= http://home.nc.rr.com/rmagick/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -27,11 +27,9 @@ USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
RUBY="${RUBY}"
+CONFIGURE_ARGS= --doc-dir="${RUBY_MODDOCDIR}"
-DOCS= ChangeLog README.txt
-
-post-patch:
- ${REINPLACE_CMD} 's:/RMagick:/doc/${RUBY_NAME}/${RUBY_MODNAME}&:' ${WRKSRC}/post-install.rb
+DOCS= ChangeLog README.html
pre-configure:
cd ${CONFIGURE_WRKSRC}; \
@@ -43,6 +41,8 @@ post-install:
.for f in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
.endfor
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${RUBY_MODEXAMPLESDIR}/
.endif
.include <bsd.port.mk>