aboutsummaryrefslogtreecommitdiff
path: root/graphics/s10sh
diff options
context:
space:
mode:
authorJosef Karthauser <joe@FreeBSD.org>2002-12-08 23:43:52 +0000
committerJosef Karthauser <joe@FreeBSD.org>2002-12-08 23:43:52 +0000
commit408830a1f16d3286276a98614e2fbec95a41f517 (patch)
treef5f5335e9fb63b851e300b8d5171b0c75af6a2e2 /graphics/s10sh
parent4837a9b0adb86034cd2e7a7b9e4bb6ac572caaf5 (diff)
Use the new version of libusb.
In addition, Kenneth Merry sent in a patch to s10sh which allows him to operate his camera. The owner of the code doesn't seem to respond to e-mail, so this functionality has been rolled in with the local patch that already existed. PR: ports/46060
Notes
Notes: svn path=/head/; revision=71445
Diffstat (limited to 'graphics/s10sh')
-rw-r--r--graphics/s10sh/Makefile4
-rw-r--r--graphics/s10sh/files/patch-usb.c25
-rw-r--r--graphics/s10sh/files/patch-usb.h12
-rw-r--r--graphics/s10sh/pkg-descr1
4 files changed, 35 insertions, 7 deletions
diff --git a/graphics/s10sh/Makefile b/graphics/s10sh/Makefile
index d06f63518cd3..50578b9e6acd 100644
--- a/graphics/s10sh/Makefile
+++ b/graphics/s10sh/Makefile
@@ -7,7 +7,7 @@
PORTNAME= s10sh
PORTVERSION= 0.2.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= http://www.reynoldsnet.org/s10sh/ \
http://www.edwinh.org/s10sh/ \
@@ -23,7 +23,7 @@ MAKEFILE= ${FILESDIR}/Makefile.bsd
.if defined(NOUSB) || defined(WITHOUT_USB)
MAKE_ENV+= WITHOUT_USB=YES
.else
-LIB_DEPENDS= usb-0.1.5:${PORTSDIR}/devel/libusb
+LIB_DEPENDS= usb-0.1.7:${PORTSDIR}/devel/libusb
.endif
.if !defined(NOPORTDOCS)
diff --git a/graphics/s10sh/files/patch-usb.c b/graphics/s10sh/files/patch-usb.c
index f7ad38e32f55..f496b2bf023a 100644
--- a/graphics/s10sh/files/patch-usb.c
+++ b/graphics/s10sh/files/patch-usb.c
@@ -1,5 +1,5 @@
---- usb.c.orig Tue Mar 13 14:46:18 2001
-+++ usb.c Sun Apr 21 00:59:11 2002
+--- usb.c.orig Tue Mar 13 06:46:18 2001
++++ usb.c Sat Dec 7 06:16:19 2002
@@ -84,6 +84,12 @@
printf("Canon S20 found\n");
return USB_INIT_S20;
@@ -13,3 +13,24 @@
case PRODUCT_ID_S100_EU:
case PRODUCT_ID_S100_US:
*camera_dev = dev;
+@@ -97,6 +103,12 @@
+ printf("Canon G1 found\n");
+ return USB_INIT_G1;
+ break;
++ case PRODUCT_ID_G3:
++ *camera_dev = dev;
++ if (opt_debug)
++ printf("Canon G3 found\n");
++ return USB_INIT_G3;
++ break;
+ case PRODUCT_ID_NEXTDIGICAM1:
+ case PRODUCT_ID_NEXTDIGICAM2:
+ case PRODUCT_ID_NEXTDIGICAM3:
+@@ -118,6 +130,7 @@
+ dev->descriptor.idProduct);
+ break;
+ }
++ break;
+ default:
+ if (opt_debug)
+ printf("Unknown vendor ID: %04X\n",
diff --git a/graphics/s10sh/files/patch-usb.h b/graphics/s10sh/files/patch-usb.h
index ab79e3dfb234..f2f0bc20e820 100644
--- a/graphics/s10sh/files/patch-usb.h
+++ b/graphics/s10sh/files/patch-usb.h
@@ -1,10 +1,12 @@
---- usb.h.orig Tue Mar 13 14:46:18 2001
-+++ usb.h Sun Apr 21 00:59:11 2002
-@@ -19,12 +19,14 @@
+--- usb.h.orig Tue Mar 13 06:46:18 2001
++++ usb.h Sat Dec 7 06:16:19 2002
+@@ -19,15 +19,20 @@
#define USB_INIT_S20 2 /* S20 found */
#define USB_INIT_S100 3 /* S100 (Digital Ixus) found */
#define USB_INIT_G1 4 /* G1 found */
+#define USB_INIT_A20 5 /* A20 found */
++#define USB_INIT_G2 6 /* G2 found */
++#define USB_INIT_G3 7 /* G3 found */
#define USB_INIT_NEW 100 /* Unsupported PowerShot found! */
#define USB_INIT_FAILED -1 /* Unable to initialize USB */
@@ -15,3 +17,7 @@
#define PRODUCT_ID_S100_US 0x3045 /* S100, aka. Digital Ixus, Elph */
#define PRODUCT_ID_S100_EU 0x3047 /* S100, aka. Digital Ixus, Elph */
#define PRODUCT_ID_G1 0x3048 /* PowerShot G1 */
++#define PRODUCT_ID_G3 0x306E
+
+ /* The Canon USB protocol of the S10, S20, S100, G1 is the same.
+ * We can hope that the next cameras will adopt a compatible protocol
diff --git a/graphics/s10sh/pkg-descr b/graphics/s10sh/pkg-descr
index 2afdb027ef60..50f08967d0ff 100644
--- a/graphics/s10sh/pkg-descr
+++ b/graphics/s10sh/pkg-descr
@@ -5,6 +5,7 @@ PowerShot camera. The interface is quite similar to DOS's command.com.
S10sh supports the following PowerShot models:
G1 (works with USB, not reported if works with the serial interface)
+ G3 (from local patches, perhaps needs further testing/debug)
S10 (serial and USB)
S20 (serial and USB)
S100 aka Digital Ixus (USB only, since it lacks the serial interface)