aboutsummaryrefslogtreecommitdiff
path: root/graphics/sam2p/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-07-02 18:23:25 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-07-02 18:23:25 +0000
commitb7e872dbeb94a5e8d92a6914e29dbe4d59e02884 (patch)
tree110c064730d617c4b68bba5e4df8b5a0c436d4d2 /graphics/sam2p/Makefile
parent13975c008a75bf404c4d87f6019192744c9d6b5a (diff)
downloadports-b7e872dbeb94a5e8d92a6914e29dbe4d59e02884.tar.gz
ports-b7e872dbeb94a5e8d92a6914e29dbe4d59e02884.zip
Notes
Diffstat (limited to 'graphics/sam2p/Makefile')
-rw-r--r--graphics/sam2p/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/graphics/sam2p/Makefile b/graphics/sam2p/Makefile
index 8f7522ce0a47..601b2977b20e 100644
--- a/graphics/sam2p/Makefile
+++ b/graphics/sam2p/Makefile
@@ -7,10 +7,10 @@
#
PORTNAME= sam2p
-PORTVERSION= 0.47
+PORTVERSION= 0.48
PORTEPOCH= 1
CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+MASTER_SITES= GOOGLE_CODE
MAINTAINER= ports@FreeBSD.org
COMMENT= Converts raster (bitmap) image formats into PS or PDF files
@@ -19,6 +19,9 @@ RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip \
cjpeg:${PORTSDIR}/graphics/jpeg \
tif22pnm:${PORTSDIR}/graphics/tif22pnm
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
USE_PERL5_BUILD= yes
USE_GHOSTSCRIPT_RUN= yes
USE_GMAKE= yes
@@ -35,11 +38,11 @@ PLIST_FILES= bin/${PORTNAME}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${EXAMPLESDIR}
@(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
.endif