aboutsummaryrefslogtreecommitdiff
path: root/graphics/sane-backends/Makefile
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2006-02-19 22:10:13 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2006-02-19 22:10:13 +0000
commitf9c920ad3ba0747c84e14c5cb79708b82f0fed08 (patch)
tree3ef1ad321ac0752c63b9c17319474b404842035f /graphics/sane-backends/Makefile
parenteca41c3e6b6878a74dd39f0f0041c47e2de65cb0 (diff)
downloadports-f9c920ad3ba0747c84e14c5cb79708b82f0fed08.tar.gz
ports-f9c920ad3ba0747c84e14c5cb79708b82f0fed08.zip
Notes
Diffstat (limited to 'graphics/sane-backends/Makefile')
-rw-r--r--graphics/sane-backends/Makefile24
1 files changed, 16 insertions, 8 deletions
diff --git a/graphics/sane-backends/Makefile b/graphics/sane-backends/Makefile
index 24192b6a594d..766c13cfafd0 100644
--- a/graphics/sane-backends/Makefile
+++ b/graphics/sane-backends/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sane-backends
PORTVERSION= 1.0.17
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://alioth.debian.org/download.php/1347/ \
ftp://ftp.sane-project.org/pub/sane/%SUBDIR%/ \
@@ -26,7 +27,6 @@ OPTIONS= USB "USB support" on \
GPHOTO2 "gPhoto2 support" off
USE_GNOME= gnometarget
-USE_REINPLACE= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -41,25 +41,33 @@ INSTALLS_SHLIB= yes
.if defined(WITHOUT_USB)
CONFIGURE_ARGS+= --disable-libusb
.else
-LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
.endif
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+= --disable-translations
-PLIST_SUB+= NLS="@comment "
+PLIST_SUB+= NLS="@comment "
.else
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
.endif
.if defined(WITH_GPHOTO2)
-LIB_DEPENDS+= gphoto2.2:${PORTSDIR}/graphics/libgphoto2
-PLIST_SUB+= GPHOTO2=""
+LIB_DEPENDS+= gphoto2.2:${PORTSDIR}/graphics/libgphoto2
+PLIST_SUB+= GPHOTO2=""
.else
CONFIGURE_ARGS+= --with-gphoto2=no
-PLIST_SUB+= GPHOTO2="@comment "
+PLIST_SUB+= GPHOTO2="@comment "
.endif
+pre-fetch:
+ @${ECHO} ""
+ @${ECHO} "*** ATTENTION ***"
+ @${ECHO} ""
+ @${ECHO} "Old versions then 1.0.17_1 do not check if you change config files."
+ @${ECHO} "If it's your case, press CTRL+C and copy your config files."
+ @${ECHO} ""
+
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|= \.\./libtool|= @LIBTOOL@|g'