aboutsummaryrefslogtreecommitdiff
path: root/graphics/scale2x
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-12-03 23:21:58 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-12-03 23:21:58 +0000
commit1ccf9254b5b8a67c5456351d294fb9fb86924ba8 (patch)
tree56fd7369d948a624855c0623d76ed32d4301bdac /graphics/scale2x
parent42ff63f8912e017692706d9f744e0ba3974acd15 (diff)
downloadports-1ccf9254b5b8a67c5456351d294fb9fb86924ba8.tar.gz
ports-1ccf9254b5b8a67c5456351d294fb9fb86924ba8.zip
Notes
Diffstat (limited to 'graphics/scale2x')
-rw-r--r--graphics/scale2x/Makefile31
-rw-r--r--graphics/scale2x/distinfo3
-rw-r--r--graphics/scale2x/pkg-descr5
3 files changed, 39 insertions, 0 deletions
diff --git a/graphics/scale2x/Makefile b/graphics/scale2x/Makefile
new file mode 100644
index 000000000000..4585223a9617
--- /dev/null
+++ b/graphics/scale2x/Makefile
@@ -0,0 +1,31 @@
+# Ports collection makefile for: scale2x
+# Date created: 2006/12/01
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= scale2x
+PORTVERSION= 2.2
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Real-time graphics effect able to increase the size of small bitmaps
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+
+USE_GETOPT_LONG=yes
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+PLIST_FILES= bin/scalex bin/scalerx
+MAN1= scalex.1 scalerx.1
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,png.h,libpng/png.h,' ${WRKSRC}/file.h
+
+.include <bsd.port.mk>
diff --git a/graphics/scale2x/distinfo b/graphics/scale2x/distinfo
new file mode 100644
index 000000000000..6fcdca42eef6
--- /dev/null
+++ b/graphics/scale2x/distinfo
@@ -0,0 +1,3 @@
+MD5 (scale2x-2.2.tar.gz) = b0a44a2d513d419354b0cf9542e62775
+SHA256 (scale2x-2.2.tar.gz) = 5784683c8d4c41741bb122b82704c08f9e1fd4fe1e0410f04917a27b27b1ed59
+SIZE (scale2x-2.2.tar.gz) = 156834
diff --git a/graphics/scale2x/pkg-descr b/graphics/scale2x/pkg-descr
new file mode 100644
index 000000000000..47658b642f98
--- /dev/null
+++ b/graphics/scale2x/pkg-descr
@@ -0,0 +1,5 @@
+Scale2x is real-time graphics effect able to increase the size of small
+bitmaps guessing the missing pixels without interpolating pixels and
+blurring the images.
+
+WWW: http://scale2x.sourceforge.net/