aboutsummaryrefslogtreecommitdiff
path: root/graphics/scantailor
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2011-04-10 20:00:33 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2011-04-10 20:00:33 +0000
commitf6fe2d99d737ec0f28bbb94a9882455fed922472 (patch)
tree1d42d4504a01d63f54328ba95807b2b5ecbaf473 /graphics/scantailor
parenta6ed0daaff4683127b187f8dab0bb0622b84ae49 (diff)
downloadports-f6fe2d99d737ec0f28bbb94a9882455fed922472.tar.gz
ports-f6fe2d99d737ec0f28bbb94a9882455fed922472.zip
Notes
Diffstat (limited to 'graphics/scantailor')
-rw-r--r--graphics/scantailor/Makefile5
-rw-r--r--graphics/scantailor/distinfo5
-rw-r--r--graphics/scantailor/files/patch-ProjectFilesDialog.cpp31
-rw-r--r--graphics/scantailor/pkg-plist2
4 files changed, 23 insertions, 20 deletions
diff --git a/graphics/scantailor/Makefile b/graphics/scantailor/Makefile
index d7504d23372f..dde90c5a8b9f 100644
--- a/graphics/scantailor/Makefile
+++ b/graphics/scantailor/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= scantailor
-PORTVERSION= 0.9.8
-PORTREVISION= 1
+PORTVERSION= 0.9.9.2
CATEGORIES= graphics
MASTER_SITES= SF
@@ -20,6 +19,8 @@ LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
png.6:${PORTSDIR}/graphics/png
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
+LICENSE= GPLv3
+
USE_CMAKE= yes
USE_ICONV= yes
USE_GETTEXT= yes
diff --git a/graphics/scantailor/distinfo b/graphics/scantailor/distinfo
index a7d691e36be4..d86468a6ef9d 100644
--- a/graphics/scantailor/distinfo
+++ b/graphics/scantailor/distinfo
@@ -1,3 +1,2 @@
-MD5 (scantailor-0.9.8.tar.gz) = ebcb7d0e5ef1d94b2026c7473cca0b35
-SHA256 (scantailor-0.9.8.tar.gz) = b79719ac20748f4199efd371f120a0c28ced012a1ea3588ce29198a041b1eb6f
-SIZE (scantailor-0.9.8.tar.gz) = 684191
+SHA256 (scantailor-0.9.9.2.tar.gz) = b65f45697c196a05ea12910ffb47ad728f98b18937c8c42033865bbdd40211c7
+SIZE (scantailor-0.9.9.2.tar.gz) = 969691
diff --git a/graphics/scantailor/files/patch-ProjectFilesDialog.cpp b/graphics/scantailor/files/patch-ProjectFilesDialog.cpp
index d14e625aa5f8..698ebeaf7993 100644
--- a/graphics/scantailor/files/patch-ProjectFilesDialog.cpp
+++ b/graphics/scantailor/files/patch-ProjectFilesDialog.cpp
@@ -1,30 +1,31 @@
---- ProjectFilesDialog.cpp.orig 2010-04-03 23:47:33.000000000 +0400
-+++ ProjectFilesDialog.cpp 2010-12-10 20:05:23.000000000 +0300
-@@ -677,6 +677,17 @@
+--- ProjectFilesDialog.cpp.orig 2011-03-29 23:54:33.000000000 +0800
++++ ProjectFilesDialog.cpp 2011-03-30 00:04:45.000000000 +0800
+@@ -677,6 +677,17 @@ ProjectFilesDialog::FileList::clear()
endRemoveRows();
}
+namespace {
-+ struct less_for_first_members_of_pairs
-+ {
-+ template <typename Pair>
-+ bool operator()(Pair const& left, Pair const& right) const
-+ {
-+ return left.first < right.first;
-+ }
-+ };
++ struct less_for_first_members_of_pairs
++ {
++ template <typename Pair>
++ bool operator()(Pair const& left, Pair const& right) const
++ {
++ return left.first < right.first;
++ }
++ };
+}
+
void
ProjectFilesDialog::FileList::remove(QItemSelection const& selection)
{
-@@ -699,7 +710,8 @@
- );
+@@ -703,7 +714,9 @@ ProjectFilesDialog::FileList::remove(QIt
+
std::sort(
sorted_ranges.begin(), sorted_ranges.end(),
-- bind(&Range::first, _1) < bind(&Range::first, _2)
-+ // bind(&Range::first, _1) < bind(&Range::first, _2)
+- bind((IntMemPtr)&Range::first, _1) < bind((IntMemPtr)&Range::first, _2)
++ //bind((IntMemPtr)&Range::first, _1) < bind((IntMemPtr)&Range::first, _2)
+ less_for_first_members_of_pairs()
++
);
QVectorIterator<Range> it(sorted_ranges);
diff --git a/graphics/scantailor/pkg-plist b/graphics/scantailor/pkg-plist
index 5dcd15f78837..7d2911f18e06 100644
--- a/graphics/scantailor/pkg-plist
+++ b/graphics/scantailor/pkg-plist
@@ -1,5 +1,7 @@
bin/scantailor
%%DATADIR%%/translations/scantailor_bg.qm
+%%DATADIR%%/translations/scantailor_de.qm
+%%DATADIR%%/translations/scantailor_fr.qm
%%DATADIR%%/translations/scantailor_ja.qm
%%DATADIR%%/translations/scantailor_ru.qm
@dirrm %%DATADIR%%/translations