aboutsummaryrefslogtreecommitdiff
path: root/graphics/sdl2_image
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2013-10-25 16:15:36 +0000
committerMarcus von Appen <mva@FreeBSD.org>2013-10-25 16:15:36 +0000
commitce01f38cc12172b564306ef9b2251fe05a30a7bf (patch)
tree83b4013587b07ed88d138efdf4521d6c416b85c2 /graphics/sdl2_image
parenta54dcd491567251f0b06e6599b4b88b77ace1e49 (diff)
Notes
Diffstat (limited to 'graphics/sdl2_image')
-rw-r--r--graphics/sdl2_image/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/graphics/sdl2_image/Makefile b/graphics/sdl2_image/Makefile
index b60c34f07c51..9b4d957d4aa7 100644
--- a/graphics/sdl2_image/Makefile
+++ b/graphics/sdl2_image/Makefile
@@ -2,7 +2,7 @@
PORTNAME= sdl2_image
PORTVERSION= 2.0.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://www.libsdl.org/projects/SDL_image/release/
DISTNAME= SDL2_image-${PORTVERSION}
@@ -10,19 +10,19 @@ DISTNAME= SDL2_image-${PORTVERSION}
MAINTAINER= mva@FreeBSD.org
COMMENT= A simple library to load images of various formats as SDL surfaces
-LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png \
- tiff:${PORTSDIR}/graphics/tiff \
- webp:${PORTSDIR}/graphics/webp
+LICENSE= ZLIB
-USES= pkgconfig:build pathfix
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libtiff.so:${PORTSDIR}/graphics/tiff \
+ libwebp.so:${PORTSDIR}/graphics/webp
+
+USES= pkgconfig:build pathfix gmake
USE_AUTOTOOLS= libtool
USE_SDL= sdl2
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lm
USE_LDCONFIG= yes
-NO_STAGE= yes
.include <bsd.port.mk>