aboutsummaryrefslogtreecommitdiff
path: root/graphics/sdl_gfx/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-05-19 21:13:41 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-05-19 21:13:41 +0000
commitc1f52005d9aabf98798149d4bd1e977aa006a9a9 (patch)
tree180379224626fb12865c3fc610c73ff7c3ed2b25 /graphics/sdl_gfx/Makefile
parent3facc1efaef892f60777acb17531cc85384dce52 (diff)
downloadports-c1f52005d9aabf98798149d4bd1e977aa006a9a9.tar.gz
ports-c1f52005d9aabf98798149d4bd1e977aa006a9a9.zip
Notes
Diffstat (limited to 'graphics/sdl_gfx/Makefile')
-rw-r--r--graphics/sdl_gfx/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/graphics/sdl_gfx/Makefile b/graphics/sdl_gfx/Makefile
index be335386f5aa..fff3879a8c6c 100644
--- a/graphics/sdl_gfx/Makefile
+++ b/graphics/sdl_gfx/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= sdl_gfx
-PORTVERSION= 2.0.10
-PORTREVISION= 2
+PORTVERSION= 2.0.11
CATEGORIES= graphics
MASTER_SITES= http://www.ferzkopp.net/~aschiffler/Software/%SUBDIR%/
MASTER_SITE_SUBDIR= SDL_gfx-${PORTVERSION:R}
@@ -20,7 +19,7 @@ COMMENT= SDL graphics drawing primitives and other support functions
USE_SDL= sdl
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_LIBTOOL_VER= 13
CONFIGURE_ARGS= --includedir=${PREFIX}/include/SDL11 \
--disable-mmx
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
@@ -36,5 +35,7 @@ CFLAGS+= -DUSE_MMX
post-patch:
@${GREP} -lR "<SDL/SDL" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|<SDL/SDL|<SDL|g'
+ @${REINPLACE_CMD} -e \
+ 's|$$(includedir)/SDL|$$(includedir)|g' ${WRKSRC}/Makefile.in
.include <bsd.port.post.mk>