aboutsummaryrefslogtreecommitdiff
path: root/graphics/sdl_gfx
diff options
context:
space:
mode:
authorSean Bruno <sbruno@FreeBSD.org>2014-09-15 15:39:03 +0000
committerSean Bruno <sbruno@FreeBSD.org>2014-09-15 15:39:03 +0000
commitba0dc3171b36d45e2517c3511a68fc7ce21e05eb (patch)
treeecedc734c41a0a398afc78c5cb2b273a33fec537 /graphics/sdl_gfx
parentdffea7048446e6161ff590efdd1f173883737e74 (diff)
Notes
Diffstat (limited to 'graphics/sdl_gfx')
-rw-r--r--graphics/sdl_gfx/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/graphics/sdl_gfx/Makefile b/graphics/sdl_gfx/Makefile
index 2b85fb09b479..c19f0668a28a 100644
--- a/graphics/sdl_gfx/Makefile
+++ b/graphics/sdl_gfx/Makefile
@@ -24,8 +24,17 @@ CONFIGURE_ARGS= --includedir=${PREFIX}/include
USE_LDCONFIG= yes
OPTIONS_DEFINE_i386= MMX
+OPTIONS_DEFINE_amd64= MMX
MMX_CONFIGURE_ENABLE= mmx
MMX_CFLAGS= -DUSE_MMX
+.include <bsd.port.options.mk>
+
+.if !${PORT_OPTIONS:MMMX}
+# Every platform not supporting the MMX knob must disable
+# MMX support explicitly
+CONFIGURE_ARGS+= --disable-mmx
+.endif
+
.include <bsd.port.mk>