aboutsummaryrefslogtreecommitdiff
path: root/graphics/sdl_gfx
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2003-08-19 05:55:07 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2003-08-19 05:55:07 +0000
commitdf09ef5a58d00770c7a0d3513c6c8005d8c32504 (patch)
tree93d03965f9fb0c1e3530f17dc305909da752e047 /graphics/sdl_gfx
parentd9d0520970e817b73c80fad4a3d4580dfddff541 (diff)
Notes
Diffstat (limited to 'graphics/sdl_gfx')
-rw-r--r--graphics/sdl_gfx/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/graphics/sdl_gfx/Makefile b/graphics/sdl_gfx/Makefile
index b65bd9999897..3648a748c014 100644
--- a/graphics/sdl_gfx/Makefile
+++ b/graphics/sdl_gfx/Makefile
@@ -20,10 +20,17 @@ USE_SDL= yes
USE_REINPLACE= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
+CONFIGURE_ARGS= --disable-mmx
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
INSTALLS_SHLIB= yes
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_MMX) && (${ARCH} == "i386")
+CFLAGS+= -DUSE_MMX
+.endif
+
post-patch:
@${REINPLACE_CMD} 's|^libSDL_gfxincludedir.*|&/SDL11|' \
${WRKSRC}/Makefile.in
@@ -31,4 +38,4 @@ post-patch:
@${REINPLACE_CMD} 's|<SDL/SDL|<SDL|g' ${WRKSRC}/${file}
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>