aboutsummaryrefslogtreecommitdiff
path: root/graphics/sdl_image/Makefile
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2014-01-18 09:12:43 +0000
committerMarcus von Appen <mva@FreeBSD.org>2014-01-18 09:12:43 +0000
commit860b5de617a97483718fcf9b04465a03e58fd3ea (patch)
tree48b18f3003dc00ae4fd90626595f060318970cc5 /graphics/sdl_image/Makefile
parent529cc5bf91a2bbf88ea98d351580eb34cc9a884a (diff)
downloadports-860b5de617a97483718fcf9b04465a03e58fd3ea.tar.gz
ports-860b5de617a97483718fcf9b04465a03e58fd3ea.zip
Notes
Diffstat (limited to 'graphics/sdl_image/Makefile')
-rw-r--r--graphics/sdl_image/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/graphics/sdl_image/Makefile b/graphics/sdl_image/Makefile
index 878ee5d2577b..02e8f1bfaba2 100644
--- a/graphics/sdl_image/Makefile
+++ b/graphics/sdl_image/Makefile
@@ -9,24 +9,24 @@ MASTER_SITES= http://www.libsdl.org/projects/SDL_image/release/
DISTNAME= SDL_image-${PORTVERSION}
MAINTAINER= mva@FreeBSD.org
-COMMENT= A simple library to load images of various formats as SDL surfaces
+COMMENT= Simple library to load images of various formats as SDL surfaces
-LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png \
- tiff:${PORTSDIR}/graphics/tiff \
- webp:${PORTSDIR}/graphics/webp
+LICENSE= LGPL21
-USES= pkgconfig:build pathfix
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libtiff.so:${PORTSDIR}/graphics/tiff \
+ libwebp.so:${PORTSDIR}/graphics/webp
+
+USES= gmake pkgconfig:build pathfix
USE_AUTOTOOLS= libtool
USE_SDL= sdl
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lm
USE_LDCONFIG= yes
-NO_STAGE= yes
post-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/.libs/showimage ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/.libs/showimage ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>