aboutsummaryrefslogtreecommitdiff
path: root/graphics/sdl_image
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-03-13 14:05:28 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-03-13 14:05:28 +0000
commitccb78bbdb7605d89c549a39672b6f3174791686b (patch)
treee10b1277e9ccee1174501d792d5b431c3029d079 /graphics/sdl_image
parentd8cae1217a649f0a359b809fc6d8450e260aa897 (diff)
downloadports-ccb78bbdb7605d89c549a39672b6f3174791686b.tar.gz
ports-ccb78bbdb7605d89c549a39672b6f3174791686b.zip
Notes
Diffstat (limited to 'graphics/sdl_image')
-rw-r--r--graphics/sdl_image/Makefile6
-rw-r--r--graphics/sdl_image/distinfo6
-rw-r--r--graphics/sdl_image/files/patch-ab13
-rw-r--r--graphics/sdl_image/files/patch-sdl_image.segfault164
-rw-r--r--graphics/sdl_image/pkg-plist3
5 files changed, 8 insertions, 184 deletions
diff --git a/graphics/sdl_image/Makefile b/graphics/sdl_image/Makefile
index 551cc0caf2bc..0033a752de90 100644
--- a/graphics/sdl_image/Makefile
+++ b/graphics/sdl_image/Makefile
@@ -6,19 +6,19 @@
#
PORTNAME= sdl_image
-PORTVERSION= 1.2.5
-PORTREVISION= 2
+PORTVERSION= 1.2.6
CATEGORIES= graphics
MASTER_SITES= http://www.libsdl.org/projects/SDL_image/release/
DISTNAME= SDL_image-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= mva@sysfault.org
COMMENT= A simple library to load images of various formats as SDL surfaces
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff
+USE_AUTOTOOLS= libtool:15
USE_SDL= sdl
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/graphics/sdl_image/distinfo b/graphics/sdl_image/distinfo
index c87f0303c66a..7b4f9beb0383 100644
--- a/graphics/sdl_image/distinfo
+++ b/graphics/sdl_image/distinfo
@@ -1,3 +1,3 @@
-MD5 (SDL_image-1.2.5.tar.gz) = cd006109a73bf7dcc93e1c3ed15ee782
-SHA256 (SDL_image-1.2.5.tar.gz) = 8a665d136fb17cc9fedcd8e42d21fcab553bd7ab67b6cafea2c6c7efe1adb308
-SIZE (SDL_image-1.2.5.tar.gz) = 1308637
+MD5 (SDL_image-1.2.6.tar.gz) = b866dc4f647517bdaf57f6ffdefd013e
+SHA256 (SDL_image-1.2.6.tar.gz) = 88fcb1dbf934af33163667a6677312065c7d0a7f01cd764e3374c4c19b386ec4
+SIZE (SDL_image-1.2.6.tar.gz) = 1308812
diff --git a/graphics/sdl_image/files/patch-ab b/graphics/sdl_image/files/patch-ab
deleted file mode 100644
index 97f04da26e83..000000000000
--- a/graphics/sdl_image/files/patch-ab
+++ /dev/null
@@ -1,13 +0,0 @@
-
-$FreeBSD$
-
---- Makefile.in.orig
-+++ Makefile.in
-@@ -255,7 +255,6 @@
-
- libSDL_image_la_LDFLAGS = \
- -no-undefined \
-- -release $(LT_RELEASE) \
- -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
-
- libSDL_image_la_LIBADD = @IMG_LIBS@
diff --git a/graphics/sdl_image/files/patch-sdl_image.segfault b/graphics/sdl_image/files/patch-sdl_image.segfault
deleted file mode 100644
index bc2e8129371b..000000000000
--- a/graphics/sdl_image/files/patch-sdl_image.segfault
+++ /dev/null
@@ -1,164 +0,0 @@
-diff -u sdl-image1.2-1.2.5/IMG_bmp.c IMG_bmp.c
---- sdl-image1.2-1.2.5/IMG_bmp.c 2006-05-14 17:57:03.000000000 -0300
-+++ IMG_bmp.c 2006-07-21 20:34:29.193015440 -0300
-@@ -36,6 +36,8 @@
- int is_BMP;
- char magic[2];
-
-+ if ( !src )
-+ return 0;
- start = SDL_RWtell(src);
- is_BMP = 0;
- if ( SDL_RWread(src, magic, sizeof(magic), 1) ) {
-diff -u sdl-image1.2-1.2.5/IMG_gif.c IMG_gif.c
---- sdl-image1.2-1.2.5/IMG_gif.c 2006-05-14 16:54:24.000000000 -0300
-+++ IMG_gif.c 2006-07-21 20:33:22.437423410 -0300
-@@ -36,6 +36,8 @@
- int is_GIF;
- char magic[6];
-
-+ if ( !src )
-+ return 0;
- start = SDL_RWtell(src);
- is_GIF = 0;
- if ( SDL_RWread(src, magic, sizeof(magic), 1) ) {
-diff -u sdl-image1.2-1.2.5/IMG_jpg.c IMG_jpg.c
---- sdl-image1.2-1.2.5/IMG_jpg.c 2006-05-14 16:54:24.000000000 -0300
-+++ IMG_jpg.c 2006-07-21 20:22:29.386350188 -0300
-@@ -179,6 +179,8 @@
- /* Blame me, not Sam, if this doesn't work right. */
- /* And don't forget to report the problem to the the sdl list too! */
-
-+ if ( !src )
-+ return 0;
- start = SDL_RWtell(src);
- is_JPG = 0;
- in_scan = 0;
-diff -u sdl-image1.2-1.2.5/IMG_lbm.c IMG_lbm.c
---- sdl-image1.2-1.2.5/IMG_lbm.c 2006-05-12 00:02:44.000000000 -0300
-+++ IMG_lbm.c 2006-07-21 20:33:14.278818049 -0300
-@@ -65,6 +65,8 @@
- int is_LBM;
- Uint8 magic[4+4+4];
-
-+ if ( !src )
-+ return 0;
- start = SDL_RWtell(src);
- is_LBM = 0;
- if ( SDL_RWread( src, magic, sizeof(magic), 1 ) )
-diff -u sdl-image1.2-1.2.5/IMG_pcx.c IMG_pcx.c
---- sdl-image1.2-1.2.5/IMG_pcx.c 2006-05-01 04:25:51.000000000 -0300
-+++ IMG_pcx.c 2006-07-21 20:25:15.919749204 -0300
-@@ -69,6 +69,8 @@
- const int PCX_RunLength_Encoding = 1;
- struct PCXheader pcxh;
-
-+ if ( !src )
-+ return 0;
- start = SDL_RWtell(src);
- is_PCX = 0;
- if ( SDL_RWread(src, &pcxh, sizeof(pcxh), 1) == 1 ) {
-diff -u sdl-image1.2-1.2.5/IMG_png.c IMG_png.c
---- sdl-image1.2-1.2.5/IMG_png.c 2006-05-14 16:54:24.000000000 -0300
-+++ IMG_png.c 2006-07-21 20:25:07.367217023 -0300
-@@ -273,6 +273,8 @@
- if ( IMG_InitPNG() < 0 ) {
- return 0;
- }
-+ if ( !src )
-+ return 0;
- start = SDL_RWtell(src);
- is_PNG = 0;
- if ( SDL_RWread(src, buf, 1, PNG_BYTES_TO_CHECK) == PNG_BYTES_TO_CHECK ) {
-diff -u sdl-image1.2-1.2.5/IMG_pnm.c IMG_pnm.c
---- sdl-image1.2-1.2.5/IMG_pnm.c 2006-05-01 04:25:51.000000000 -0300
-+++ IMG_pnm.c 2006-07-21 20:26:06.881005273 -0300
-@@ -44,6 +44,8 @@
- int is_PNM;
- char magic[2];
-
-+ if ( !src )
-+ return 0;
- start = SDL_RWtell(src);
- is_PNM = 0;
- if ( SDL_RWread(src, magic, sizeof(magic), 1) ) {
-diff -u sdl-image1.2-1.2.5/IMG_tif.c IMG_tif.c
---- sdl-image1.2-1.2.5/IMG_tif.c 2006-07-21 20:31:17.000000000 -0300
-+++ IMG_tif.c 2006-07-21 20:27:09.959187601 -0300
-@@ -189,6 +189,8 @@
- if ( IMG_InitTIF() < 0 ) {
- return 0;
- }
-+ if ( !src )
-+ return 0;
- start = SDL_RWtell(src);
- is_TIF = 0;
-
-diff -u sdl-image1.2-1.2.5/IMG_xcf.c IMG_xcf.c
---- sdl-image1.2-1.2.5/IMG_xcf.c 2006-05-01 04:25:51.000000000 -0300
-+++ IMG_xcf.c 2006-07-21 20:28:49.113194657 -0300
-@@ -213,6 +213,8 @@
- int is_XCF;
- char magic[14];
-
-+ if ( !src )
-+ return 0;
- start = SDL_RWtell(src);
- is_XCF = 0;
- if ( SDL_RWread(src, magic, sizeof(magic), 1) ) {
-diff -u sdl-image1.2-1.2.5/IMG_xpm.c IMG_xpm.c
---- sdl-image1.2-1.2.5/IMG_xpm.c 2006-05-12 00:02:44.000000000 -0300
-+++ IMG_xpm.c 2006-07-21 20:33:29.517213256 -0300
-@@ -59,6 +59,8 @@
- int is_XPM;
- char magic[9];
-
-+ if ( !src )
-+ return 0;
- start = SDL_RWtell(src);
- is_XPM = 0;
- if ( SDL_RWread(src, magic, sizeof(magic), 1) ) {
-@@ -326,7 +328,8 @@
- linebuf = NULL;
- buflen = 0;
-
-- start = SDL_RWtell(src);
-+ if ( src )
-+ start = SDL_RWtell(src);
-
- if(xpm)
- xpmlines = &xpm;
-@@ -453,7 +456,8 @@
-
- done:
- if(error) {
-- SDL_RWseek(src, start, SEEK_SET);
-+ if ( src )
-+ SDL_RWseek(src, start, SEEK_SET);
- if ( image ) {
- SDL_FreeSurface(image);
- image = NULL;
-diff -u sdl-image1.2-1.2.5/IMG_xv.c IMG_xv.c
---- sdl-image1.2-1.2.5/IMG_xv.c 2006-05-01 04:25:51.000000000 -0300
-+++ IMG_xv.c 2006-07-21 20:29:16.504502815 -0300
-@@ -89,6 +89,8 @@
- int is_XV;
- int w, h;
-
-+ if ( !src )
-+ return 0;
- start = SDL_RWtell(src);
- is_XV = 0;
- if ( get_header(src, &w, &h) == 0 ) {
-diff -u sdl-image1.2-1.2.5/IMG_xxx.c IMG_xxx.c
---- sdl-image1.2-1.2.5/IMG_xxx.c 2006-05-01 04:25:51.000000000 -0300
-+++ IMG_xxx.c 2006-07-21 20:29:57.169539262 -0300
-@@ -34,6 +34,8 @@
- int start;
- int is_XXX;
-
-+ if ( !src )
-+ return 0;
- start = SDL_RWtell(src);
- is_XXX = 0;
-
diff --git a/graphics/sdl_image/pkg-plist b/graphics/sdl_image/pkg-plist
index 6762a1e3d345..63430bec42fe 100644
--- a/graphics/sdl_image/pkg-plist
+++ b/graphics/sdl_image/pkg-plist
@@ -1,7 +1,8 @@
bin/showimage
include/SDL/SDL_image.h
+lib/libSDL_image-1.2.so
+lib/libSDL_image-1.2.so.1
lib/libSDL_image.a
lib/libSDL_image.la
lib/libSDL_image.so
-lib/libSDL_image.so.1
@dirrmtry include/SDL