aboutsummaryrefslogtreecommitdiff
path: root/graphics/sdl_ttf
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:54:54 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:54:54 +0000
commit29747f458a1eb2ce23b4594b09d0256dd62760b8 (patch)
tree1b71ba5d9ffdd308b6c18130f7c116f5bab5dc12 /graphics/sdl_ttf
parent7aad84f808b93baa6a7077ce0b47573b9c4c79a0 (diff)
downloadports-29747f458a1eb2ce23b4594b09d0256dd62760b8.tar.gz
ports-29747f458a1eb2ce23b4594b09d0256dd62760b8.zip
Notes
Diffstat (limited to 'graphics/sdl_ttf')
-rw-r--r--graphics/sdl_ttf/Makefile1
-rw-r--r--graphics/sdl_ttf/files/patch-SDL_ttf.c19
2 files changed, 20 insertions, 0 deletions
diff --git a/graphics/sdl_ttf/Makefile b/graphics/sdl_ttf/Makefile
index 91acaa6da329..c355211a1e2d 100644
--- a/graphics/sdl_ttf/Makefile
+++ b/graphics/sdl_ttf/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sdl_ttf
PORTVERSION= 2.0.8
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://www.libsdl.org/projects/SDL_ttf/release/
DISTNAME= SDL_ttf-${PORTVERSION}
diff --git a/graphics/sdl_ttf/files/patch-SDL_ttf.c b/graphics/sdl_ttf/files/patch-SDL_ttf.c
new file mode 100644
index 000000000000..dbfadc22790f
--- /dev/null
+++ b/graphics/sdl_ttf/files/patch-SDL_ttf.c
@@ -0,0 +1,19 @@
+--- SDL_ttf.c.orig Mon May 1 05:26:17 2006
++++ SDL_ttf.c Sun Sep 24 15:46:44 2006
+@@ -48,7 +48,6 @@
+ #include <freetype/ftoutln.h>
+ #include <freetype/ttnameid.h>
+ */
+-#include <freetype/internal/ftobjs.h>
+
+ #ifndef FT_OPEN_STREAM
+ #define FT_OPEN_STREAM ft_open_stream
+@@ -278,7 +277,7 @@
+ }
+ memset(stream, 0, sizeof(*stream));
+
+- stream->memory = library->memory;
++ stream->memory = NULL;
+ stream->read = RWread;
+ stream->descriptor.pointer = src;
+ stream->pos = (unsigned long)position;