aboutsummaryrefslogtreecommitdiff
path: root/graphics/sdl_ttf
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-09-20 16:17:38 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-09-20 16:17:38 +0000
commit3bef99738467627fcdb903c736ea338fd95a7a64 (patch)
treeae726a224de17bf903ebd3561fb4c802a290b7b3 /graphics/sdl_ttf
parent886612c43d1e22d6353678f7f8cd2e1f45d7f0dc (diff)
downloadports-3bef99738467627fcdb903c736ea338fd95a7a64.tar.gz
ports-3bef99738467627fcdb903c736ea338fd95a7a64.zip
Notes
Diffstat (limited to 'graphics/sdl_ttf')
-rw-r--r--graphics/sdl_ttf/Makefile34
-rw-r--r--graphics/sdl_ttf/distinfo1
-rw-r--r--graphics/sdl_ttf/files/patch-aa11
-rw-r--r--graphics/sdl_ttf/pkg-comment1
-rw-r--r--graphics/sdl_ttf/pkg-descr15
-rw-r--r--graphics/sdl_ttf/pkg-plist5
6 files changed, 67 insertions, 0 deletions
diff --git a/graphics/sdl_ttf/Makefile b/graphics/sdl_ttf/Makefile
new file mode 100644
index 000000000000..6dd6cda18e3a
--- /dev/null
+++ b/graphics/sdl_ttf/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: sdl_ttf
+# Date created: 20 September 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sdl_ttf
+PORTVERSION= 1.2.1
+CATEGORIES= graphics
+MASTER_SITES= http://www.devolution.com/~slouken/SDL/projects/SDL_ttf/src/
+DISTNAME= SDL_ttf-${PORTVERSION}
+
+MAINTAINER= sobomax@FreeBSD.org
+
+LIB_DEPENDS= SDL-1.1.2:${PORTSDIR}/devel/sdl-devel
+
+SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
+
+USE_LIBTOOL= yes
+USE_GMAKE= yes
+USE_FREETYPE= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
+
+post-extract:
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|-release \$$\(LT_RELEASE\)||g'
+
+post-configure:
+ @${PERL} -pi -e 's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
+ ${WRKSRC}/libtool
+
+.include <bsd.port.mk>
diff --git a/graphics/sdl_ttf/distinfo b/graphics/sdl_ttf/distinfo
new file mode 100644
index 000000000000..0b6d4c707341
--- /dev/null
+++ b/graphics/sdl_ttf/distinfo
@@ -0,0 +1 @@
+MD5 (SDL_ttf-1.2.1.tar.gz) = 33374f5a8dd0f96b5e4bf42fcb6c6399
diff --git a/graphics/sdl_ttf/files/patch-aa b/graphics/sdl_ttf/files/patch-aa
new file mode 100644
index 000000000000..5db8bf34a370
--- /dev/null
+++ b/graphics/sdl_ttf/files/patch-aa
@@ -0,0 +1,11 @@
+--- Makefile.in 2000/09/20 16:08:11 1.1
++++ Makefile.in 2000/09/20 16:08:25
+@@ -89,7 +89,7 @@
+
+ lib_LTLIBRARIES = libSDL_ttf.la
+
+-libSDL_ttfincludedir = $(includedir)/SDL
++libSDL_ttfincludedir = $(includedir)/SDL11
+ libSDL_ttfinclude_HEADERS = SDL_ttf.h
+
+
diff --git a/graphics/sdl_ttf/pkg-comment b/graphics/sdl_ttf/pkg-comment
new file mode 100644
index 000000000000..d0bcdef605dc
--- /dev/null
+++ b/graphics/sdl_ttf/pkg-comment
@@ -0,0 +1 @@
+A library to use TrueType fonts to render text in SDL applications
diff --git a/graphics/sdl_ttf/pkg-descr b/graphics/sdl_ttf/pkg-descr
new file mode 100644
index 000000000000..e03d20ad1ec7
--- /dev/null
+++ b/graphics/sdl_ttf/pkg-descr
@@ -0,0 +1,15 @@
+This library is a wrapper around the excellent FreeType library.
+
+WARNING: There may be patent issues with using the FreeType library. Check the
+FreeType website for up-to-date details.
+
+This library allows you to use TrueType fonts to render text in SDL
+applications.
+
+Be careful when including fonts with your application, as many of them are
+copyrighted. The Microsoft fonts, for example, are not freely redistributable
+and even the free "web" fonts they provide are only redistributable in their
+special executable installer form (May 1998). There are plenty of freeware and
+shareware fonts available on the Internet though, and may suit your purposes.
+
+WWW: http://www.devolution.com/~slouken/SDL/projects/SDL_ttf/
diff --git a/graphics/sdl_ttf/pkg-plist b/graphics/sdl_ttf/pkg-plist
new file mode 100644
index 000000000000..7a2686915cea
--- /dev/null
+++ b/graphics/sdl_ttf/pkg-plist
@@ -0,0 +1,5 @@
+bin/showfont
+include/SDL11/SDL_ttf.h
+lib/libSDL_ttf.a
+lib/libSDL_ttf.so
+lib/libSDL_ttf.so.0