aboutsummaryrefslogtreecommitdiff
path: root/graphics/sdl_ttf
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2014-01-18 09:37:49 +0000
committerMarcus von Appen <mva@FreeBSD.org>2014-01-18 09:37:49 +0000
commit585d077324d4864e473b072b158124d4b62358e1 (patch)
treeee7a59f412d1125ac63e7763e3b3d12aba17b462 /graphics/sdl_ttf
parent5dd3a62f842f2be279ad56d7fbf8830bea001b9b (diff)
Notes
Diffstat (limited to 'graphics/sdl_ttf')
-rw-r--r--graphics/sdl_ttf/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/graphics/sdl_ttf/Makefile b/graphics/sdl_ttf/Makefile
index 4265e70c7966..f840f8cd0794 100644
--- a/graphics/sdl_ttf/Makefile
+++ b/graphics/sdl_ttf/Makefile
@@ -8,25 +8,29 @@ MASTER_SITES= http://www.libsdl.org/projects/SDL_ttf/release/
DISTNAME= SDL_ttf-${PORTVERSION}
MAINTAINER= mva@FreeBSD.org
-COMMENT= A library to use TrueType fonts to render text in SDL applications
+COMMENT= Library to use TrueType fonts to render text in SDL applications
-LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+LICENSE= ZLIB
+
+LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
USE_AUTOTOOLS= libtool
USE_SDL= sdl
USES= gmake pathfix pkgconfig
+USE_XORG= x11
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
-.if !defined(WITHOUT_X11) && !defined(WITHOUT_GL)
-USE_GL= yes
-.endif
+OPTIONS_DEFINE= OPENGL
+OPTIONS_DEFAULT= OPENGL
+
+OPENGL_USE= GL=yes
-NO_STAGE= yes
post-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/.libs/glfont ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/.libs/showfont ${PREFIX}/bin/sdl-showfont
+ ${INSTALL_PROGRAM} ${WRKSRC}/.libs/glfont ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/.libs/showfont \
+ ${STAGEDIR}${PREFIX}/bin/sdl-showfont
.include <bsd.port.mk>