aboutsummaryrefslogtreecommitdiff
path: root/graphics/sharpconstruct
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-03-13 16:13:31 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-03-13 16:13:31 +0000
commitc50ae2c70e8784f3d0f91884bc809ffd975f0c61 (patch)
tree06ac5fafe89d3c4c95a50fa191e45ae3755054d9 /graphics/sharpconstruct
parentf5ad7b48a8844f75d19d657acba802e2156d8d0c (diff)
downloadports-c50ae2c70e8784f3d0f91884bc809ffd975f0c61.tar.gz
ports-c50ae2c70e8784f3d0f91884bc809ffd975f0c61.zip
- Add ONLY_FOR_ARCHS
Notes: The software uses SSE, so it won't compile on sparc64; add proper ONLY_FOR_ARCHS and ONLY_FOR_ARCHS_REASON PR: 121551 Submitted by: Dmitry Marakasov <amdmi3@amdmi3.ru> (maintainer)
Notes
Notes: svn path=/head/; revision=208972
Diffstat (limited to 'graphics/sharpconstruct')
-rw-r--r--graphics/sharpconstruct/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/graphics/sharpconstruct/Makefile b/graphics/sharpconstruct/Makefile
index aa1dcc6c7a65..808583ccfbad 100644
--- a/graphics/sharpconstruct/Makefile
+++ b/graphics/sharpconstruct/Makefile
@@ -24,14 +24,12 @@ USE_GL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-MAN1= sharpconstruct.1
+ONLY_FOR_ARCHS= i386 amd64
+ONLY_FOR_ARCHS_REASON= uses SSE
-.include <bsd.port.pre.mk>
+MAN1= sharpconstruct.1
post-patch:
-.if ${ARCH} != "i386" && ${ARCH} != "amd64"
- @${REINPLACE_CMD} -e 's|-msse||' ${WRKSRC}/src/Makefile*
-.endif
@${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/include/Align.hh
@${REINPLACE_CMD} -e 's|"/sharpconstruct|"|' ${WRKSRC}/src/MainWindow.cc
@${REINPLACE_CMD} -e 's|/usr/share/sharpconstruct|${DATADIR}|' ${WRKSRC}/src/MainWindow.cc
@@ -40,4 +38,4 @@ post-patch:
@${FIND} ${WRKSRC} -name Makefile.in -print0 | ${XARGS} -0 \
${REINPLACE_CMD} -e '/^DEFS / s|$$| -DDATADIR=\\"${DATADIR}\\"|'
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>