aboutsummaryrefslogtreecommitdiff
path: root/graphics/shotwell
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2018-07-15 16:57:54 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2018-07-15 16:57:54 +0000
commita187f4593a5a732788863554b1e8b4439fb9d249 (patch)
tree64bbc9b02fd391860ffb33f9a13c486a49f93181 /graphics/shotwell
parent32c8a26e27a4280f446e558efbffd95f7c4da2b7 (diff)
downloadports-a187f4593a5a732788863554b1e8b4439fb9d249.tar.gz
ports-a187f4593a5a732788863554b1e8b4439fb9d249.zip
Notes
Diffstat (limited to 'graphics/shotwell')
-rw-r--r--graphics/shotwell/Makefile2
-rw-r--r--graphics/shotwell/distinfo6
-rw-r--r--graphics/shotwell/files/patch-configure.ac2
-rw-r--r--graphics/shotwell/files/patch-src_camera_CameraTable.vala (renamed from graphics/shotwell/files/patch-src-camera-CameraTable.vala)56
4 files changed, 11 insertions, 55 deletions
diff --git a/graphics/shotwell/Makefile b/graphics/shotwell/Makefile
index eb2b0272a0d7..f9c25d14dbec 100644
--- a/graphics/shotwell/Makefile
+++ b/graphics/shotwell/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= shotwell
-PORTVERSION= 0.28.3
+PORTVERSION= 0.28.4
CATEGORIES= graphics gnome
MASTER_SITES= GNOME/sources/shotwell/${PORTVERSION:R}
diff --git a/graphics/shotwell/distinfo b/graphics/shotwell/distinfo
index 9fefdda603b6..74d67d2044dc 100644
--- a/graphics/shotwell/distinfo
+++ b/graphics/shotwell/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1525791684
-SHA256 (shotwell-0.28.3.tar.xz) = d08603f3736f9791c1d7fcfe586ffaaf07b05e18cff370c94c07d8f23e06d403
-SIZE (shotwell-0.28.3.tar.xz) = 5531900
+TIMESTAMP = 1531658607
+SHA256 (shotwell-0.28.4.tar.xz) = a976f5ab972e8448a1509fa0dc132e4b40d94d3d7c8c33dc0cc1e25fa7b0670e
+SIZE (shotwell-0.28.4.tar.xz) = 5529712
diff --git a/graphics/shotwell/files/patch-configure.ac b/graphics/shotwell/files/patch-configure.ac
index 6ef6f12a42ae..b9bf8b735be7 100644
--- a/graphics/shotwell/files/patch-configure.ac
+++ b/graphics/shotwell/files/patch-configure.ac
@@ -1,4 +1,4 @@
---- configure.ac.orig 2018-03-17 13:41:22 UTC
+--- configure.ac.orig 2018-07-15 15:12:12 UTC
+++ configure.ac
@@ -114,7 +114,6 @@ PKG_CHECK_MODULES(SHOTWELL, [
gstreamer-plugins-base-1.0 >= 1.0.0
diff --git a/graphics/shotwell/files/patch-src-camera-CameraTable.vala b/graphics/shotwell/files/patch-src_camera_CameraTable.vala
index 3ec7686e9f2e..6972df6b9647 100644
--- a/graphics/shotwell/files/patch-src-camera-CameraTable.vala
+++ b/graphics/shotwell/files/patch-src_camera_CameraTable.vala
@@ -1,4 +1,4 @@
---- src/camera/CameraTable.vala.orig 2018-03-10 06:42:15 UTC
+--- src/camera/CameraTable.vala.orig 2018-07-15 15:10:47 UTC
+++ src/camera/CameraTable.vala
@@ -26,7 +26,6 @@ public class CameraTable {
@@ -16,51 +16,10 @@
volume_monitor = VolumeMonitor.get();
volume_monitor.volume_changed.connect(on_volume_changed);
volume_monitor.volume_added.connect(on_volume_changed);
-@@ -107,36 +105,10 @@ public class CameraTable {
- do_op(GPhoto.CameraAbilitiesList.create(out abilities_list), "create camera abilities list");
- do_op(abilities_list.load(null_context), "load camera abilities list");
- }
--
-+
-+ // dummy stub - the original requires udev
- private string[] get_all_usb_cameras() {
-- string[] cameras = new string[0];
--
-- GLib.List<GUdev.Device> device_list = client.query_by_subsystem(null);
-- foreach (GUdev.Device device in device_list) {
-- string device_file = device.get_device_file();
-- if(
-- // only keep devices that have a non-null device file and that
-- // have both the ID_GPHOTO2 and GPHOTO2_DRIVER properties set
-- (device_file != null) &&
-- (device.has_property("ID_GPHOTO2")) &&
-- (device.has_property("GPHOTO2_DRIVER"))
-- ) {
-- int camera_bus, camera_device;
-- // extract the bus and device IDs from the device file string
-- // TODO: is it safe to parse the absolute path or should we be
-- // smarter and use a regex to only pick up the end of the path?
-- if (device_file.scanf("/dev/bus/usb/%d/%d", out camera_bus, out camera_device) < 2) {
-- critical("get_all_usb_cameras: Failed to scanf device file %s", device_file);
--
-- continue;
-- }
-- string camera = "usb:%.3d,%.3d".printf(camera_bus, camera_device);
-- debug("USB camera detected at %s", camera);
-- cameras += camera;
-- }
-- }
--
-- return cameras;
-+ return new string[0];
- }
-
- // USB (or libusb) is a funny beast; if only one USB device is present (i.e. the camera),
-@@ -211,24 +183,8 @@ public class CameraTable {
- return port.has_prefix("usb:") ?
+@@ -118,23 +116,7 @@ public class CameraTable {
"/dev/bus/usb/%s".printf(port.substring(4).replace(",", "/")) : null;
}
--
+
- private string? get_name_for_uuid(string uuid) {
- foreach (Volume volume in volume_monitor.get_volumes()) {
- if (volume.get_identifier(VolumeIdentifier.UUID) == uuid) {
@@ -78,12 +37,11 @@
- }
- return null;
- }
-+
+ // get_name_for_uuid() and get_icon_for_uuid() are not used (udev removal)
private void update_camera_table() throws GPhotoError {
// need to do this because virtual ports come and go in the USB world (and probably others)
-@@ -326,23 +282,7 @@ public class CameraTable {
+@@ -221,23 +203,7 @@ public class CameraTable {
}
// Get display name for camera.
@@ -108,11 +66,10 @@
if (port.has_prefix("disk:")) {
try {
var mount = File.new_for_path (port.substring(5)).find_enclosing_mount();
-@@ -391,14 +331,8 @@ public class CameraTable {
- camera_added(camera);
+@@ -287,13 +253,7 @@ public class CameraTable {
}
}
--
+
- private void on_udev_event(string action, GUdev.Device device) {
- debug("udev event: %s on %s", action, device.get_name());
-
@@ -120,7 +77,6 @@
- // update to occur when they come in all at once
- camera_update_scheduler.after_timeout(UPDATE_DELAY_MSEC, true);
- }
-+
+ // on_udev_event() removed - we do not have udev
public void on_volume_changed(Volume volume) {