aboutsummaryrefslogtreecommitdiff
path: root/graphics/showimage
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2011-12-13 16:26:40 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2011-12-13 16:26:40 +0000
commit135e376db2c0edca8c8bf968c9b77f13b232dbc5 (patch)
tree2785f61858be4472dc8cae5ab99f4f604d58b164 /graphics/showimage
parent8b47c307d1d5d0b94dae18d4d7bda03608929ae9 (diff)
downloadports-135e376db2c0edca8c8bf968c9b77f13b232dbc5.tar.gz
ports-135e376db2c0edca8c8bf968c9b77f13b232dbc5.zip
Notes
Diffstat (limited to 'graphics/showimage')
-rw-r--r--graphics/showimage/Makefile30
-rw-r--r--graphics/showimage/distinfo2
-rw-r--r--graphics/showimage/files/patch-CMakeLists.txt17
-rw-r--r--graphics/showimage/files/patch-showimage.desktop11
-rw-r--r--graphics/showimage/pkg-descr5
5 files changed, 65 insertions, 0 deletions
diff --git a/graphics/showimage/Makefile b/graphics/showimage/Makefile
new file mode 100644
index 000000000000..684f6564931d
--- /dev/null
+++ b/graphics/showimage/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: showimage
+# Date Created: 2011-11-26
+# Whom: Rusty Nejdl <rnejdl@ringofsaturn.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= showimage
+PORTVERSION= 1.6.3
+CATEGORIES= graphics kde
+MASTER_SITES= http://www.kde-apps.org/CONTENT/content-files/
+DISTNAME= 143977-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= rnejdl@ringofsaturn.com
+COMMENT= ShowImage is a simple KDE based image viewer
+
+USE_BZIP2= yes
+USE_CMAKE= yes
+USE_KDE4= automoc4 kdeprefix kdelibs
+USE_QT_VER= 4
+QT_COMPONENTS= qmake_build moc_build rcc_build uic_build
+MAKE_JOBS_SAFE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+PLIST_FILES= bin/${PORTNAME}-kde4 \
+ share/applications/kde4/${PORTNAME}.desktop \
+ share/icons/hicolor/32x32/apps/${PORTNAME}.png
+
+.include <bsd.port.mk>
diff --git a/graphics/showimage/distinfo b/graphics/showimage/distinfo
new file mode 100644
index 000000000000..a287797af865
--- /dev/null
+++ b/graphics/showimage/distinfo
@@ -0,0 +1,2 @@
+SHA256 (143977-showimage-1.6.3.tar.bz2) = e8189fa8fda0e6a4654906629793345574025228ac512b7167c6509132087ff9
+SIZE (143977-showimage-1.6.3.tar.bz2) = 22702
diff --git a/graphics/showimage/files/patch-CMakeLists.txt b/graphics/showimage/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..53d52939dd56
--- /dev/null
+++ b/graphics/showimage/files/patch-CMakeLists.txt
@@ -0,0 +1,17 @@
+--- ./CMakeLists.txt.orig 2011-08-17 14:50:52.000000000 +0000
++++ ./CMakeLists.txt 2011-12-13 16:02:16.768599808 +0000
+@@ -13,11 +13,11 @@
+
+ kde4_add_ui_files(showimage_SRCS)
+
+-kde4_add_executable(showimage ${showimage_SRCS})
++kde4_add_executable(showimage-kde4 ${showimage_SRCS})
+
+-target_link_libraries(showimage ${KDE4_KDEUI_LIBS} ${KDE4_KIO_LIBS})
++target_link_libraries(showimage-kde4 ${KDE4_KDEUI_LIBS} ${KDE4_KIO_LIBS})
+
+-install(TARGETS showimage ${INSTALL_TARGETS_DEFAULT_ARGS})
++install(TARGETS showimage-kde4 ${INSTALL_TARGETS_DEFAULT_ARGS})
+ install(FILES showimage.desktop DESTINATION ${XDG_APPS_INSTALL_DIR})
+
+ kde4_install_icons(${ICON_INSTALL_DIR})
diff --git a/graphics/showimage/files/patch-showimage.desktop b/graphics/showimage/files/patch-showimage.desktop
new file mode 100644
index 000000000000..931f310abecc
--- /dev/null
+++ b/graphics/showimage/files/patch-showimage.desktop
@@ -0,0 +1,11 @@
+--- ./showimage.desktop.orig 2011-09-12 19:22:18.000000000 +0000
++++ ./showimage.desktop 2011-12-13 15:58:11.884599087 +0000
+@@ -2,7 +2,7 @@
+ Type=Application
+ Encoding=UTF-8
+ Exec=showimage %F
+-Icon=showimage
++Icon=showimage-kde4
+ Categories=Graphics;RasterGraphics;Viewer;
+ Terminal=false
+
diff --git a/graphics/showimage/pkg-descr b/graphics/showimage/pkg-descr
new file mode 100644
index 000000000000..d506d5c9f5dc
--- /dev/null
+++ b/graphics/showimage/pkg-descr
@@ -0,0 +1,5 @@
+ShowImage is a simple KDE based image viewer using the maximum space
+inside its window without cluttering the window with menubar, toolbar
+or statusbar.
+
+WWW: http://kde-apps.org/content/show.php/ShowImage?content=143977