aboutsummaryrefslogtreecommitdiff
path: root/graphics/simage
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-18 14:01:03 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-18 14:01:03 +0000
commitde4e578ac2a6784a89ff92da0a4723541ed1c5fb (patch)
tree3f61dd405c40e0922755334d487eb7a4a9db4837 /graphics/simage
parentf3375f8bd5a20669ef4e81e168bdf6dac4e7bd3b (diff)
downloadports-de4e578ac2a6784a89ff92da0a4723541ed1c5fb.tar.gz
ports-de4e578ac2a6784a89ff92da0a4723541ed1c5fb.zip
add simape 1.2.2
Library with image format loaders and front-ends PR: 37920 Submitted by: Roland Jesse <jesse@cs.uni-magdeburg.de>
Notes
Notes: svn path=/head/; revision=66602
Diffstat (limited to 'graphics/simage')
-rw-r--r--graphics/simage/Makefile30
-rw-r--r--graphics/simage/distinfo1
-rw-r--r--graphics/simage/pkg-comment1
-rw-r--r--graphics/simage/pkg-descr10
-rw-r--r--graphics/simage/pkg-plist14
5 files changed, 56 insertions, 0 deletions
diff --git a/graphics/simage/Makefile b/graphics/simage/Makefile
new file mode 100644
index 000000000000..bf94045697d4
--- /dev/null
+++ b/graphics/simage/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: simage
+# Date created: 10 May 2002
+# Whom: jesse@cs.uni-magdeburg.de
+#
+# $FreeBSD$
+#
+
+PORTNAME= simage
+PORTVERSION= 1.2.2
+CATEGORIES= graphics
+MASTER_SITES= ftp://ftp.coin3d.org/pub/coin/src/
+
+MAINTAINER= jesse@cs.uni-magdeburg.de
+
+BUILD_DEPENDS= guile:${PORTSDIR}/lang/guile
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png \
+ ungif.5:${PORTSDIR}/graphics/libungif
+
+USE_REINPLACE= yes
+USE_LIBTOOL= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --program-transform-name="s/x/x/"
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|malloc.h|stdlib.h|g" ${WRKSRC}/src/resize.c
+
+.include <bsd.port.mk>
diff --git a/graphics/simage/distinfo b/graphics/simage/distinfo
new file mode 100644
index 000000000000..7763c38770a9
--- /dev/null
+++ b/graphics/simage/distinfo
@@ -0,0 +1 @@
+MD5 (simage-1.2.2.tar.gz) = 5f5e9a560b692600d8999539446ec259
diff --git a/graphics/simage/pkg-comment b/graphics/simage/pkg-comment
new file mode 100644
index 000000000000..1b74ee79a72b
--- /dev/null
+++ b/graphics/simage/pkg-comment
@@ -0,0 +1 @@
+Library with image format loaders and front-ends
diff --git a/graphics/simage/pkg-descr b/graphics/simage/pkg-descr
new file mode 100644
index 000000000000..11c82e5961e2
--- /dev/null
+++ b/graphics/simage/pkg-descr
@@ -0,0 +1,10 @@
+From its README:
+
+This is ``simage'', a library with image format loaders and front-ends
+to common import libraries. simage is meant for use with applications
+which reads image files as textures.
+
+WWW: http://www.coin3d.org/
+
+ Roland
+jesse@cs.uni-magdeburg.de
diff --git a/graphics/simage/pkg-plist b/graphics/simage/pkg-plist
new file mode 100644
index 000000000000..77f82e4e57ba
--- /dev/null
+++ b/graphics/simage/pkg-plist
@@ -0,0 +1,14 @@
+bin/simage-convert.scm
+bin/simage-config
+include/simage.h
+include/guilesimage.h
+lib/libsimage.so
+lib/libsimage.so.22
+lib/libguilesimage.so
+lib/libguilesimage.so.0
+share/aclocal/simage.m4
+share/guile/coin/simage.scm
+share/Coin/conf/simage-default.cfg
+@dirrm share/guile/coin
+@unexec rmdir %D/share/Coin/conf 2>/dev/null || true
+@unexec rmdir %D/share/Coin 2>/dev/null || true