aboutsummaryrefslogtreecommitdiff
path: root/graphics/sodipodi
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-02-08 06:53:59 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-02-08 06:53:59 +0000
commit2c5b12fb15181c8562eacdfb3af71d5bb1c07ed6 (patch)
tree9424db1aa6622f138863abf848c074720bc1d3e5 /graphics/sodipodi
parentbcc278eb69241acc735811ab9811c08ac167ccc4 (diff)
downloadports-2c5b12fb15181c8562eacdfb3af71d5bb1c07ed6.tar.gz
ports-2c5b12fb15181c8562eacdfb3af71d5bb1c07ed6.zip
Notes
Diffstat (limited to 'graphics/sodipodi')
-rw-r--r--graphics/sodipodi/Makefile11
-rw-r--r--graphics/sodipodi/distinfo2
-rw-r--r--graphics/sodipodi/files/patch-configure135
-rw-r--r--graphics/sodipodi/pkg-plist1
4 files changed, 9 insertions, 140 deletions
diff --git a/graphics/sodipodi/Makefile b/graphics/sodipodi/Makefile
index 0b1fbb1a3b34..1b40838e3b69 100644
--- a/graphics/sodipodi/Makefile
+++ b/graphics/sodipodi/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= sodipodi
-PORTVERSION= 0.29
-PORTREVISION= 1
+PORTVERSION= 0.30
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,15 +14,15 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= gnome@FreeBSD.org
BUILD_DEPENDS= ${X11BASE}/libdata/pkgconfig/frontline.pc:${PORTSDIR}/graphics/frontline
-LIB_DEPENDS= gnomeprintui-2-2.0:${PORTSDIR}/x11-toolkits/libgnomeprintui
+LIB_DEPENDS= glade-2.0.0:${PORTSDIR}/devel/libglade2
RUN_DEPENDS= ${X11BASE}/libdata/pkgconfig/frontline.pc:${PORTSDIR}/graphics/frontline
-BROKEN= "Requires update for libgnomeprint-2-2"
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_GNOMENG= yes
USE_GNOME= gnomeprefix gnomehack
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --without-gnome-print
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
@@ -33,5 +32,9 @@ MAN1= sodipodi.1
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|X11/Xft/Xft\.h|X11/Xft/Xft2.h|g' \
+ ${WRKSRC}/configure \
+ ${WRKSRC}/src/libnrtype/nr-type-xft.c
+
.include <bsd.port.mk>
diff --git a/graphics/sodipodi/distinfo b/graphics/sodipodi/distinfo
index 6c25e5d25996..9f12b915007b 100644
--- a/graphics/sodipodi/distinfo
+++ b/graphics/sodipodi/distinfo
@@ -1 +1 @@
-MD5 (sodipodi-0.29.tar.gz) = 9610cae5790e6a852bdf0176e040256f
+MD5 (sodipodi-0.30.tar.gz) = 5a246ab594ad985a27fd3e7240fa97e1
diff --git a/graphics/sodipodi/files/patch-configure b/graphics/sodipodi/files/patch-configure
index 4b679dab8fab..cca6980c9eda 100644
--- a/graphics/sodipodi/files/patch-configure
+++ b/graphics/sodipodi/files/patch-configure
@@ -18,138 +18,3 @@
ac_ext=c
ac_cpp='$CPP $CPPFLAGS'
-@@ -3786,7 +3790,7 @@
- fi
-
-
--if test "x${prefix}" == "xNONE"; then
-+if test "x${prefix}" = "xNONE"; then
-
- cat >>confdefs.h <<_ACEOF
- #define PACKAGE_LOCALE_DIR "${ac_default_prefix}/${DATADIRNAME}/locale"
-@@ -7154,7 +7158,7 @@
- echo "${ECHO_T}no" >&6
- fi
-
--if test "x$PKG_CONFIG" == "xno"; then
-+if test "x$PKG_CONFIG" = "xno"; then
- { { echo "$as_me:$LINENO: error: You have to install pkg-config to compile sodipodi." >&5
- echo "$as_me: error: You have to install pkg-config to compile sodipodi." >&2;}
- { (exit 1); exit 1; }; }
-@@ -7280,7 +7284,7 @@
-
-
- if test "x$popt_ok" != "xyes"; then
-- if test "x$with_popt" == "xyes"; then
-+ if test "x$with_popt" = "xyes"; then
- { { echo "$as_me:$LINENO: error: --with-popt was specified, but appropriate development packages could not be found" >&5
- echo "$as_me: error: --with-popt was specified, but appropriate development packages could not be found" >&2;}
- { (exit 1); exit 1; }; }
-@@ -7294,7 +7298,7 @@
-
-
-
--if test "x$popt_ok" == "xyes"; then
-+if test "x$popt_ok" = "xyes"; then
- USE_POPT_TRUE=
- USE_POPT_FALSE='#'
- else
-@@ -7302,7 +7306,7 @@
- USE_POPT_FALSE=
- fi
-
--if test "x$popt_ok" == "xyes"; then
-+if test "x$popt_ok" = "xyes"; then
-
- cat >>confdefs.h <<\_ACEOF
- #define WITH_POPT 1
-@@ -7430,7 +7434,7 @@
-
-
- if test "x$xft_ok" != "xyes"; then
-- if test "x$with_xft" == "xyes"; then
-+ if test "x$with_xft" = "xyes"; then
- { { echo "$as_me:$LINENO: error: --with-xft was specified, but appropriate development packages could not be found" >&5
- echo "$as_me: error: --with-xft was specified, but appropriate development packages could not be found" >&2;}
- { (exit 1); exit 1; }; }
-@@ -7442,7 +7446,7 @@
-
-
-
--if test "x$xft_ok" == "xyes"; then
-+if test "x$xft_ok" = "xyes"; then
- USE_XFT_TRUE=
- USE_XFT_FALSE='#'
- else
-@@ -7450,7 +7454,7 @@
- USE_XFT_FALSE=
- fi
-
--if test "x$xft_ok" == "xyes"; then
-+if test "x$xft_ok" = "xyes"; then
-
- cat >>confdefs.h <<\_ACEOF
- #define WITH_XFT 1
-@@ -7567,7 +7571,7 @@
- fi
-
- if test "x$gp" != "xyes"; then
-- if test "x$with_gp" == "xyes"; then
-+ if test "x$with_gp" = "xyes"; then
- { { echo "$as_me:$LINENO: error: --with-gnome-print was specified, but appropriate libgnomeprint development packages could not found" >&5
- echo "$as_me: error: --with-gnome-print was specified, but appropriate libgnomeprint development packages could not found" >&2;}
- { (exit 1); exit 1; }; }
-@@ -7582,7 +7586,7 @@
-
-
-
--if test "x$gp" == "xyes"; then
-+if test "x$gp" = "xyes"; then
- USE_GNOME_PRINT_TRUE=
- USE_GNOME_PRINT_FALSE='#'
- else
-@@ -7590,7 +7594,7 @@
- USE_GNOME_PRINT_FALSE=
- fi
-
--if test "x$gp" == "xyes"; then
-+if test "x$gp" = "xyes"; then
-
- cat >>confdefs.h <<\_ACEOF
- #define WITH_GNOME_PRINT 1
-@@ -7736,8 +7740,8 @@
- echo "$as_me:$LINENO: checking compiler support for MMX" >&5
- echo $ECHO_N "checking compiler support for MMX... $ECHO_C" >&6
-
--if test x$enable_mmx == xauto ; then
-- if test $use_x86_asm == yes; then
-+if test x$enable_mmx = xauto ; then
-+ if test $use_x86_asm = yes; then
- save_ac_ext=$ac_ext
- ac_ext=S
-
-@@ -7753,13 +7757,13 @@
- ac_ext=$save_ac_ext
- fi
-
--elif test x$enable_mmx == xyes ; then
-+elif test x$enable_mmx = xyes ; then
- use_mmx_asm=yes
- else
- use_mmx_asm=no
- fi
-
--if test $use_mmx_asm == yes; then
-+if test $use_mmx_asm = yes; then
-
- cat >>confdefs.h <<\_ACEOF
- #define WITH_MMX 1
-@@ -7774,7 +7778,7 @@
-
-
-
--if test x$use_mmx_asm == xyes; then
-+if test x$use_mmx_asm = xyes; then
- USE_MMX_TRUE=
- USE_MMX_FALSE='#'
- else
diff --git a/graphics/sodipodi/pkg-plist b/graphics/sodipodi/pkg-plist
index 8af714de337f..5d9a42c10122 100644
--- a/graphics/sodipodi/pkg-plist
+++ b/graphics/sodipodi/pkg-plist
@@ -175,6 +175,7 @@ share/gnome/sodipodi/zoom_in.xpm
share/gnome/sodipodi/zoom_out.xpm
share/gnome/sodipodi/zoom_page.xpm
share/gnome/sodipodi/zoom_select.xpm
+share/locale/am/LC_MESSAGES/sodipodi.mo
share/locale/az/LC_MESSAGES/sodipodi.mo
share/locale/ca/LC_MESSAGES/sodipodi.mo
share/locale/cs/LC_MESSAGES/sodipodi.mo