aboutsummaryrefslogtreecommitdiff
path: root/graphics/sodipodi
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-10-01 06:39:34 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-10-01 06:39:34 +0000
commit718ad37dfb0c6b3e83ec7945dbcd3ec2e222557e (patch)
treef327d01dbad94c6c564e9cc42902c28804321655 /graphics/sodipodi
parent9814ea77d2056df99ff2fc976785909cc058e048 (diff)
downloadports-718ad37dfb0c6b3e83ec7945dbcd3ec2e222557e.tar.gz
ports-718ad37dfb0c6b3e83ec7945dbcd3ec2e222557e.zip
Notes
Diffstat (limited to 'graphics/sodipodi')
-rw-r--r--graphics/sodipodi/Makefile7
-rw-r--r--graphics/sodipodi/distinfo2
-rw-r--r--graphics/sodipodi/files/patch-configure23
-rw-r--r--graphics/sodipodi/files/patch-po::Makefile.in.in32
-rw-r--r--graphics/sodipodi/files/patch-src::sp-text.c14
-rw-r--r--graphics/sodipodi/pkg-plist1
6 files changed, 75 insertions, 4 deletions
diff --git a/graphics/sodipodi/Makefile b/graphics/sodipodi/Makefile
index 90494c43fdac..b2e6370a1274 100644
--- a/graphics/sodipodi/Makefile
+++ b/graphics/sodipodi/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= sodipodi
-PORTVERSION= 0.23
-PORTREVISION= 1
+PORTVERSION= 0.24
CATEGORIES= graphics gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -21,10 +20,12 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
+MAN1= sodipodi.1
+
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
diff --git a/graphics/sodipodi/distinfo b/graphics/sodipodi/distinfo
index 75347c5ad604..2763195ed7cb 100644
--- a/graphics/sodipodi/distinfo
+++ b/graphics/sodipodi/distinfo
@@ -1 +1 @@
-MD5 (sodipodi-0.23.tar.gz) = 947dcc478cb871b36da72b5938c466df
+MD5 (sodipodi-0.24.tar.gz) = 87cbb29d00a5ad2c9ec84a45bf5c0431
diff --git a/graphics/sodipodi/files/patch-configure b/graphics/sodipodi/files/patch-configure
new file mode 100644
index 000000000000..e57c7d1e01fd
--- /dev/null
+++ b/graphics/sodipodi/files/patch-configure
@@ -0,0 +1,23 @@
+
+$FreeBSD$
+
+--- configure 2001/09/28 13:29:15 1.1
++++ configure 2001/09/28 13:29:37
+@@ -3974,7 +3974,7 @@
+ fi
+
+
+- CATOBJEXT=.gmo
++ CATOBJEXT=.mo
+ fi
+
+ else
+@@ -4096,7 +4096,7 @@
+
+ BUILD_INCLUDED_LIBINTL=yes
+ USE_INCLUDED_LIBINTL=yes
+- CATOBJEXT=.gmo
++ CATOBJEXT=.mo
+ INTLLIBS="\$(top_builddir)/intl/libintl.a $LIBICONV"
+ LIBS=`echo " $LIBS " | sed -e 's/ -lintl / /' -e 's/^ //' -e 's/ $//'`
+ fi
diff --git a/graphics/sodipodi/files/patch-po::Makefile.in.in b/graphics/sodipodi/files/patch-po::Makefile.in.in
new file mode 100644
index 000000000000..b60d540218c1
--- /dev/null
+++ b/graphics/sodipodi/files/patch-po::Makefile.in.in
@@ -0,0 +1,32 @@
+
+$FreeBSD$
+
+--- po/Makefile.in.in 2001/09/28 13:21:12 1.1
++++ po/Makefile.in.in 2001/09/28 13:21:31
+@@ -106,7 +106,7 @@
+ @catalogs='$(CATALOGS)'; \
+ for cat in $$catalogs; do \
+ cat=`basename $$cat`; \
+- lang=`echo $$cat | sed 's/\.gmo$$//'`; \
++ lang=`echo $$cat | sed 's/\.mo$$//'`; \
+ dir=$(localedir)/$$lang/LC_MESSAGES; \
+ $(mkinstalldirs) $(DESTDIR)$$dir; \
+ if test -r $$cat; then \
+@@ -126,7 +126,7 @@
+ catalogs='$(CATALOGS)'; \
+ for cat in $$catalogs; do \
+ cat=`basename $$cat`; \
+- lang=`echo $$cat | sed 's/\.gmo$$//'`; \
++ lang=`echo $$cat | sed 's/\.mo$$//'`; \
+ rm -f $(DESTDIR)$(localedir)/$$lang/LC_MESSAGES/$(PACKAGE).mo; \
+ done
+ if test "$(PACKAGE)" = "gettext"; then \
+@@ -172,7 +172,7 @@
+ catalogs='$(GMOFILES)'; \
+ for cat in $$catalogs; do \
+ cat=`basename $$cat`; \
+- lang=`echo $$cat | sed 's/\.gmo$$//'`; \
++ lang=`echo $$cat | sed 's/\.mo$$//'`; \
+ echo "$$lang:"; \
+ if $(MSGMERGE) $$lang.po $(PACKAGE).pot -o $$lang.new.po; then \
+ mv -f $$lang.new.po $$lang.po; \
diff --git a/graphics/sodipodi/files/patch-src::sp-text.c b/graphics/sodipodi/files/patch-src::sp-text.c
new file mode 100644
index 000000000000..ff27cb0bdf10
--- /dev/null
+++ b/graphics/sodipodi/files/patch-src::sp-text.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/sp-text.c 2001/09/28 13:10:32 1.1
++++ src/sp-text.c 2001/09/28 13:19:21
+@@ -235,7 +235,7 @@
+ x = text->x;
+ y += text->size;
+ } else {
+- g_unichar_to_utf8 (btowc(*c), utfbuf);
++ g_unichar_to_utf8 (*c, utfbuf);
+ glyph = gnome_font_face_lookup_default (face, g_utf8_get_char(utfbuf));
+
+ w = gnome_font_face_get_glyph_width (face, glyph);
diff --git a/graphics/sodipodi/pkg-plist b/graphics/sodipodi/pkg-plist
index c6e3b6198e9b..bdaac230e8e4 100644
--- a/graphics/sodipodi/pkg-plist
+++ b/graphics/sodipodi/pkg-plist
@@ -50,6 +50,7 @@ share/gnome/sodipodi/display.glade
share/gnome/sodipodi/div.xpm
share/gnome/sodipodi/document.c
share/gnome/sodipodi/document.glade
+share/gnome/sodipodi/draw_dynahand.xpm
share/gnome/sodipodi/draw_ellipse.xpm
share/gnome/sodipodi/draw_freehand.xpm
share/gnome/sodipodi/draw_node.xpm