aboutsummaryrefslogtreecommitdiff
path: root/graphics/spcaview
diff options
context:
space:
mode:
authorHajimu UMEMOTO <ume@FreeBSD.org>2005-04-17 08:25:42 +0000
committerHajimu UMEMOTO <ume@FreeBSD.org>2005-04-17 08:25:42 +0000
commitf42a08edb117a8a109c04a388169c0a0e3474dff (patch)
tree2b9ab79799da25e957ecf7aa6ac2f3993b8f88ab /graphics/spcaview
parent2de10d38a4e70b18683457351c39da48dfc5c246 (diff)
downloadports-f42a08edb117a8a109c04a388169c0a0e3474dff.tar.gz
ports-f42a08edb117a8a109c04a388169c0a0e3474dff.zip
Notes
Diffstat (limited to 'graphics/spcaview')
-rw-r--r--graphics/spcaview/Makefile45
-rw-r--r--graphics/spcaview/distinfo4
-rw-r--r--graphics/spcaview/pkg-descr24
3 files changed, 73 insertions, 0 deletions
diff --git a/graphics/spcaview/Makefile b/graphics/spcaview/Makefile
new file mode 100644
index 000000000000..0ae4af8c1cff
--- /dev/null
+++ b/graphics/spcaview/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: spca5xx
+# Date created: 21 March 2005
+# Whom: Yoshihiko Sarumaru <mistral@imasy.or.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= spca5xx
+PORTVERSION= 20050206
+CATEGORIES= graphics
+MASTER_SITES= http://mxhaard.free.fr/spca50x/Download/
+
+PATCH_SITES= http://www2.starcat.ne.jp/~takam/bsd/
+PATCHFILES= spca5xx-bsd-0.3b.patch.gz
+PATCH_DIST_STRIP= -p3
+
+MAINTAINER= mistral@imasy.or.jp
+COMMENT= USB Cameras based SPCA5xx Utilities
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/drivers/usb
+
+.if defined(WITHOUT_X11)
+COMPONENTS= spca5shot
+.else
+USE_GNOME= imlib gtk12
+COMPONENTS= spca5shot spca5view
+.endif
+
+MAN1= ${COMPONENTS:S/$/.1/}
+MANCOMPRESSED= yes
+PLIST_FILES= ${COMPONENTS:S/^/bin\//}
+
+MAKE_ARGS+= MANDIR=${MANPREFIX}/man/man
+
+do-build:
+.for component in ${COMPONENTS}
+ @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} Makefile.${component} ${MAKE_ARGS} ${ALL_TARGET})
+.endfor
+
+do-install:
+.for component in ${COMPONENTS}
+ @(cd ${INSTALL_WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} Makefile.${component} ${MAKE_ARGS} ${INSTALL_TARGET})
+.endfor
+
+.include <bsd.port.mk>
diff --git a/graphics/spcaview/distinfo b/graphics/spcaview/distinfo
new file mode 100644
index 000000000000..47ef99752c20
--- /dev/null
+++ b/graphics/spcaview/distinfo
@@ -0,0 +1,4 @@
+MD5 (spca5xx-20050206.tar.gz) = 309b55f83238147ce2d0ff82961f1ce9
+SIZE (spca5xx-20050206.tar.gz) = 147019
+MD5 (spca5xx-bsd-0.3b.patch.gz) = 50f08ce2e320c61f5675e1c9b25fb6a7
+SIZE (spca5xx-bsd-0.3b.patch.gz) = 25917
diff --git a/graphics/spcaview/pkg-descr b/graphics/spcaview/pkg-descr
new file mode 100644
index 000000000000..60576b77978b
--- /dev/null
+++ b/graphics/spcaview/pkg-descr
@@ -0,0 +1,24 @@
+USB Cameras based SPCA5xx Utilities for NetBSD
+-----------------------------------------------
+1. What is it?
+ They are patches from SPCA5xx chipset linux driver to be worked on *BSD,
+ There is included two userland programs as follow;
+ spca5shot ... simple image capture program.
+ spca5view ... sequential image viewer program.
+
+2. Supported USB cameras
+ Vendor Device Product Name
+ ------ ------ ------------
+ 0x041e 0x403a Creative webcam nx pro
+ 0x04fc 0x0561 FlexiCam B100
+ 0x0572 0x0041 Creative webcam notebook PD1170
+ 0x060b 0xa001 Maxell CompactPC Camera PM3
+ 0x0733 0x0401 Intel CS330
+ 0x0ac8 0x301b LOAS MCM-H06SL
+ 0x0ac8 0x301b sanwa CMS-V11
+ 0x0c45 0x6025 LOAS MCM-S02SL ( 352x288 not worked )
+ 0x0c45 0x6025 VGA WEB CAMERA "WEB CAM." ( 352x288 not worked )
+ 0x0c45 0x6029 Raccoon AM-ST3
+ 0xabcd 0xcdee SIGMA-APO Petcam
+
+WWW: http://www2.starcat.ne.jp/~takam/bsd/NetBSD.html#spca561