aboutsummaryrefslogtreecommitdiff
path: root/graphics/sswf
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-10-08 16:47:00 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-10-08 16:47:00 +0000
commit3251205bdc2201e7ee047a04449de4373cad3721 (patch)
treef8a2b1d6d6d53f9049b7cab55cd63fbe5241fccf /graphics/sswf
parent43b17b8b7ca698a2138ddbc5a1f7330de2b8aebe (diff)
Notes
Diffstat (limited to 'graphics/sswf')
-rw-r--r--graphics/sswf/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/graphics/sswf/Makefile b/graphics/sswf/Makefile
index c74c35f4c6ae..0dec0bf858f4 100644
--- a/graphics/sswf/Makefile
+++ b/graphics/sswf/Makefile
@@ -9,10 +9,10 @@ MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= ports@FreeBSD.org
-COMMENT= A library and script language tool to create Flash movies
+COMMENT= Library and script language tool to create Flash movies
-LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- freetype.9:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libfreetype.so:${PORTSDIR}/print/freetype2
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -26,9 +26,17 @@ PLIST_SUB= VERSION="${PORTVERSION}"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.if !defined(WITH_DEBUG)
+OPTIONS_DEFINE= DEBUG
+
+.include <bsd.port.options.mk>
+
+.if ! ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --disable-debug --disable-yydebug
.endif
-NO_STAGE= yes
+post-configure:
+ @${REINPLACE_CMD} 's|ICONV_INPUT_CAST||' \
+ ${WRKSRC}/src/lib/libsswf_tag_header.c++ \
+ ${WRKSRC}/src/sswf/sswf_lexical.c++
+
.include <bsd.port.mk>