aboutsummaryrefslogtreecommitdiff
path: root/graphics/stl2pov/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-10 19:45:30 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-10 19:45:30 +0000
commitd5e8829bd1bd7c64cf7c4a5dd6146ce459134ecb (patch)
tree244650f6f38f37689f644c0ce16db90d6dbaff39 /graphics/stl2pov/Makefile
parent04f5574229eb38ecd3743c7faa1c88f039fe2dea (diff)
downloadports-d5e8829bd1bd7c64cf7c4a5dd6146ce459134ecb.tar.gz
ports-d5e8829bd1bd7c64cf7c4a5dd6146ce459134ecb.zip
Notes
Diffstat (limited to 'graphics/stl2pov/Makefile')
-rw-r--r--graphics/stl2pov/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/graphics/stl2pov/Makefile b/graphics/stl2pov/Makefile
new file mode 100644
index 000000000000..8c8c98a76111
--- /dev/null
+++ b/graphics/stl2pov/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: stl2pov
+# Date created: 9 May 2005
+# Whom: rsmith@xs4all.nl
+#
+# $FreeBSD$
+
+PORTNAME= stl2pov
+PORTVERSION= 2.2.1
+CATEGORIES= graphics
+MASTER_SITES= http://www.xs4all.nl/~rsmith/software/
+
+MAINTAINER= rsmith@xs4all.nl
+COMMENT= Converts STL models to POV-Ray meshes
+
+USE_REINPLACE= yes
+
+PLIST_FILES= bin/stl2pov
+
+MAN1= stl2pov.1
+MANCOMPRESSED= yes
+
+.if defined(NOPORTDOCS)
+MAKE_ENV= NOPORTDOCS=yes
+.else
+PORTDOCS= LICENSE README INSTALL
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|-pipe||; s|-fmerge-constants||; s|--fast-math||' \
+ ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>