aboutsummaryrefslogtreecommitdiff
path: root/graphics/structuresynth/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-06-18 23:59:12 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-06-18 23:59:12 +0000
commit3ec74c77d02901af1d44878c44b6da98cdc45202 (patch)
tree25708f56d1867342622bdaf439a55d1414a99d59 /graphics/structuresynth/Makefile
parent60f7295e70bd61503e8ab0ec23822eb2915e9be2 (diff)
downloadports-3ec74c77d02901af1d44878c44b6da98cdc45202.tar.gz
ports-3ec74c77d02901af1d44878c44b6da98cdc45202.zip
Notes
Diffstat (limited to 'graphics/structuresynth/Makefile')
-rw-r--r--graphics/structuresynth/Makefile27
1 files changed, 11 insertions, 16 deletions
diff --git a/graphics/structuresynth/Makefile b/graphics/structuresynth/Makefile
index 6725caf56771..847c57a4e7cf 100644
--- a/graphics/structuresynth/Makefile
+++ b/graphics/structuresynth/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= structuresynth
-PORTVERSION= 0.7.0
-PORTREVISION= 1
+PORTVERSION= 0.8.0
CATEGORIES= graphics
MASTER_SITES= SF
DISTNAME= StructureSynth-Source-v${PORTVERSION}
@@ -17,32 +16,28 @@ COMMENT= Rule-based 3D structure generator
USE_ZIP= yes
USE_QT_VER= 4
-QT_COMPONENTS= qmake corelib gui opengl moc rcc
+QT_COMPONENTS= qmake corelib gui opengl moc rcc xml
-WRKSRC= ${WRKDIR}/source/trunk
+WRKSRC= ${WRKDIR}/structuresynth
+
+post-extract:
+ ${MV} ${WRKDIR}/"Structure Synth Source Code" ${WRKDIR}/structuresynth
post-patch:
@${REINPLACE_CMD} -e 's|"Examples"|"${DATADIR}/Examples"|; \
s|"Misc"|"${DATADIR}/Misc"|' ${WRKSRC}/MainWindow.cpp
do-configure:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} -project
+ @${ECHO_CMD} "QT+=opengl xml" >> ${WRKSRC}/structuresynth.pro
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} \
- -project
- @${ECHO_CMD} "QT+=opengl" >> ${WRKSRC}/trunk.pro
- @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${QMAKE} \
- -spec ${QMAKESPEC} trunk.pro
+ -spec ${QMAKESPEC} structuresynth.pro
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/trunk ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/structuresynth ${PREFIX}/bin/${PORTNAME}
${MKDIR} ${DATADIR}/Examples
${INSTALL_DATA} ${WRKSRC}/Examples/*.es ${DATADIR}/Examples
${MKDIR} ${DATADIR}/Misc
${INSTALL_DATA} ${WRKSRC}/Misc/* ${DATADIR}/Misc
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 600000
-BROKEN= Does not compile
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>