aboutsummaryrefslogtreecommitdiff
path: root/graphics/structuresynth
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-06-18 11:46:51 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-06-18 11:46:51 +0000
commit3037cb61c7f1ac5ae9a15cee2365daa2d4036028 (patch)
treee391a5b5894d27043bb95bd6680b03174979f810 /graphics/structuresynth
parent28eb882aa04c420b3fe972dd8748b80c90c5cd82 (diff)
downloadports-3037cb61c7f1ac5ae9a15cee2365daa2d4036028.tar.gz
ports-3037cb61c7f1ac5ae9a15cee2365daa2d4036028.zip
- Trim Makefile headers
- Drop ABI versions from LIB_DEPENDS - OptionsNG - Pet portlint - Switch to dynamic plist where useful
Notes
Notes: svn path=/head/; revision=321181
Diffstat (limited to 'graphics/structuresynth')
-rw-r--r--graphics/structuresynth/Makefile7
-rw-r--r--graphics/structuresynth/files/patch-SyntopiaCore__GLEngine__Raytracer__RayTracer.cpp16
-rw-r--r--graphics/structuresynth/files/patch-SyntopiaCore__GLEngine__Sphere.h16
3 files changed, 18 insertions, 21 deletions
diff --git a/graphics/structuresynth/Makefile b/graphics/structuresynth/Makefile
index 6f78916e2a80..dc99128db5cf 100644
--- a/graphics/structuresynth/Makefile
+++ b/graphics/structuresynth/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: structuresynth
-# Date created: 06 Apr 2008
-# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
-#
+# Created by: Dmitry Marakasov <amdmi3@amdmi3.ru>
# $FreeBSD$
-#
PORTNAME= structuresynth
PORTVERSION= 1.5.0
@@ -20,6 +16,7 @@ USE_ZIP= yes
USE_QT4= qmake_build corelib gui opengl moc_build rcc_build xml script
MAKE_JOBS_SAFE= yes
WRKSRC= ${WRKDIR}/structure-synth
+USE_DOS2UNIX= *.cpp *.h
post-extract:
@${MV} "${WRKDIR}/Structure Synth Source Code" ${WRKSRC}
diff --git a/graphics/structuresynth/files/patch-SyntopiaCore__GLEngine__Raytracer__RayTracer.cpp b/graphics/structuresynth/files/patch-SyntopiaCore__GLEngine__Raytracer__RayTracer.cpp
index 73940063bde5..501304daeef3 100644
--- a/graphics/structuresynth/files/patch-SyntopiaCore__GLEngine__Raytracer__RayTracer.cpp
+++ b/graphics/structuresynth/files/patch-SyntopiaCore__GLEngine__Raytracer__RayTracer.cpp
@@ -1,11 +1,11 @@
--- ./SyntopiaCore/GLEngine/Raytracer/RayTracer.cpp~ 2012-05-20 01:28:31.000000000 -0300
+++ ./SyntopiaCore/GLEngine/Raytracer/RayTracer.cpp 2012-05-20 01:28:47.000000000 -0300
@@ -7,6 +7,8 @@
- #include "SyntopiaCore/Logging/Logging.h"
- #include "SyntopiaCore/Misc/MiniParser.h"
-
-+#include <GL/glu.h>
-+
- using namespace SyntopiaCore::Math;
- using namespace SyntopiaCore::Misc;
-
+ #include "SyntopiaCore/Logging/Logging.h"
+ #include "SyntopiaCore/Misc/MiniParser.h"
+
++#include <GL/glu.h>
++
+ using namespace SyntopiaCore::Math;
+ using namespace SyntopiaCore::Misc;
+
diff --git a/graphics/structuresynth/files/patch-SyntopiaCore__GLEngine__Sphere.h b/graphics/structuresynth/files/patch-SyntopiaCore__GLEngine__Sphere.h
index 671be4a09ccb..fca363622d8d 100644
--- a/graphics/structuresynth/files/patch-SyntopiaCore__GLEngine__Sphere.h
+++ b/graphics/structuresynth/files/patch-SyntopiaCore__GLEngine__Sphere.h
@@ -1,11 +1,11 @@
--- ./SyntopiaCore/GLEngine/Sphere.h~ 2012-05-20 01:25:41.000000000 -0300
+++ ./SyntopiaCore/GLEngine/Sphere.h 2012-05-20 01:25:59.000000000 -0300
@@ -3,6 +3,8 @@
- #include "SyntopiaCore/Math/Vector3.h"
- #include "Object3D.h"
-
-+#include <GL/glu.h>
-+
- namespace SyntopiaCore {
- namespace GLEngine {
-
+ #include "SyntopiaCore/Math/Vector3.h"
+ #include "Object3D.h"
+
++#include <GL/glu.h>
++
+ namespace SyntopiaCore {
+ namespace GLEngine {
+