aboutsummaryrefslogtreecommitdiff
path: root/graphics/svgfig
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2008-06-03 15:12:04 +0000
committerWesley Shields <wxs@FreeBSD.org>2008-06-03 15:12:04 +0000
commite9786637d7b15e050894ddcd835e5f028b476a11 (patch)
tree34323d84157b3a3a875f55cf03a6330641d68ad9 /graphics/svgfig
parenta878d849c750989c45147efa53cc0ebfb894f17e (diff)
downloadports-e9786637d7b15e050894ddcd835e5f028b476a11.tar.gz
ports-e9786637d7b15e050894ddcd835e5f028b476a11.zip
Notes
Diffstat (limited to 'graphics/svgfig')
-rw-r--r--graphics/svgfig/Makefile27
-rw-r--r--graphics/svgfig/distinfo3
-rw-r--r--graphics/svgfig/pkg-descr21
-rw-r--r--graphics/svgfig/pkg-plist4
4 files changed, 55 insertions, 0 deletions
diff --git a/graphics/svgfig/Makefile b/graphics/svgfig/Makefile
new file mode 100644
index 000000000000..1b11ac2131c8
--- /dev/null
+++ b/graphics/svgfig/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: svgfig
+# Date created: 01 June 2008
+# Whom: Wesley Shields <wxs@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SVGFig
+PORTVERSION= 1.1.6
+CATEGORIES= graphics python
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME:L}-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= wxs@FreeBSD.org
+COMMENT= Draw mathematical figures in SVG using Python
+
+WRKSRC= ${WRKDIR}/${PORTNAME:L}
+
+USE_PYTHON= 2.4+
+USE_PYDISTUTILS= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|1.1.2|${PORTVERSION}|' ${WRKSRC}/setup.py
+
+.include <bsd.port.mk>
diff --git a/graphics/svgfig/distinfo b/graphics/svgfig/distinfo
new file mode 100644
index 000000000000..11386f5824ff
--- /dev/null
+++ b/graphics/svgfig/distinfo
@@ -0,0 +1,3 @@
+MD5 (svgfig-1.1.6.tgz) = 3e283bd6fd6e3ade1d3a21f33e805045
+SHA256 (svgfig-1.1.6.tgz) = cfc98c662178011b4e5edf64a5bb4190eec523ddabfec3355e8e9101e499cd46
+SIZE (svgfig-1.1.6.tgz) = 25552
diff --git a/graphics/svgfig/pkg-descr b/graphics/svgfig/pkg-descr
new file mode 100644
index 000000000000..4df03cf2f033
--- /dev/null
+++ b/graphics/svgfig/pkg-descr
@@ -0,0 +1,21 @@
+The SVGFig package lets you draw mathematical figures in Scalable
+Vector Graphics format (SVG), using the Python language.
+
+As a tool, its usefulness lies somewhere between freehand drawing
+programs, which don't give you quantitative control over your figures,
+and traditional plotting packages, which fit your data into a prescribed
+template. SVGFig allows you to draw anything you can express in Python.
+
+SVGFig is particularly suited to handle non-linear geometries. All
+lines, including the coordinate axis, curve if passed through a
+non-linear coordinate transformation, and coordinate systems can be
+nested in trees. This generalizes all the tools necessary for making
+plots, so it is easy to create polar plots of radial data, Hammer-Aitoff
+projections of the sky, translations in hyperbolic spaces, or experiment
+with new representations.
+
+SVGFig also maintains a convenient representation of SVG images as
+Python constructs, so you can load graphics from SVG files, dissect
+them, manipulate them with an automated script, and save them in batch.
+
+WWW: http://code.google.com/p/svgfig/
diff --git a/graphics/svgfig/pkg-plist b/graphics/svgfig/pkg-plist
new file mode 100644
index 000000000000..1a4c4aa3939a
--- /dev/null
+++ b/graphics/svgfig/pkg-plist
@@ -0,0 +1,4 @@
+%%PYTHON_SITELIBDIR%%/svgfig.py
+%%PYTHON_SITELIBDIR%%/svgfig.pyo
+%%PYTHON_SITELIBDIR%%/svgfig.pyc
+@dirrmtry %%PYTHON_SITELIBDIR%%