aboutsummaryrefslogtreecommitdiff
path: root/graphics/swfdec/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2004-12-15 18:50:49 +0000
committerKoop Mast <kwm@FreeBSD.org>2004-12-15 18:50:49 +0000
commit1e029bdb85b05da93cb2fd0e073fda182937fdb8 (patch)
tree55e94a6910633e895c61395dbd21a1d968858928 /graphics/swfdec/Makefile
parente59be8137cd5a6eb50c139e4c876dd59aa5b8aa2 (diff)
Update to version 0.3.2 [1].
Grab maintainership PR: 74362 [1] Submitted by: ijliao
Notes
Notes: svn path=/head/; revision=124150
Diffstat (limited to 'graphics/swfdec/Makefile')
-rw-r--r--graphics/swfdec/Makefile25
1 files changed, 11 insertions, 14 deletions
diff --git a/graphics/swfdec/Makefile b/graphics/swfdec/Makefile
index fb0b2043cb8d..69ea1ff981c0 100644
--- a/graphics/swfdec/Makefile
+++ b/graphics/swfdec/Makefile
@@ -7,33 +7,30 @@
#
PORTNAME= swfdec
-PORTVERSION= 0.2.2
-PORTREVISION= 6
+PORTVERSION= 0.3.2
CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= http://www.schleef.org/swfdec/download/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= kwm@FreeBSD.org
COMMENT= Flash Rendering Library
-LIB_DEPENDS= mad.2:${PORTSDIR}/audio/libmad
+LIB_DEPENDS= mad.2:${PORTSDIR}/audio/libmad \
+ oil-0.2.0:${PORTSDIR}/devel/liboil
+USE_REINPLACE= yes
USE_X_PREFIX= yes
USE_SDL= sdl
USE_GNOME= gnomehack gtk20 libartlgpl2
USE_GETOPT_LONG= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
INSTALLS_SHLIB= yes
-CPPFLAGS= -I${LOCALBASE}/include
-LDFLAGS= -L${LOCALBASE}/lib
-
-.include <bsd.port.pre.mk>
+PLIST_SUB= VERSION=${PORTVERSION:R}
post-patch:
- @${REINPLACE_CMD} -e "s|sdl-config|${SDL_CONFIG:T}|g" ${WRKSRC}/configure
- @${REINPLACE_CMD} -e "s|malloc\.h|stdlib.h|g" ${WRKSRC}/libswfdec/jpeg/sl_types.h
+ @${REINPLACE_CMD} -e "s,int16_t,__int16_t," ${WRKSRC}/libswfdec/swfdec_shape.c
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>