aboutsummaryrefslogtreecommitdiff
path: root/graphics/swfdec/Makefile
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2007-07-14 15:33:18 +0000
committerEric Anholt <anholt@FreeBSD.org>2007-07-14 15:33:18 +0000
commitc431230f60563e0866d00f7d29f9ac16e24d8d9f (patch)
tree3bcaecb7a5552d10b111edb228b7df56018eb327 /graphics/swfdec/Makefile
parentcb1cd985215de5652470808b3c3d08f964da72ab (diff)
Update swfdec and swfdec-plugin to 0.5.0.
The primary feature of this release is a rewrite of the scripting engine for better correctness. The ports are also improved to remove dependencies that haven't existed since the 0.4 series.
Notes
Notes: svn path=/head/; revision=195580
Diffstat (limited to 'graphics/swfdec/Makefile')
-rw-r--r--graphics/swfdec/Makefile16
1 files changed, 4 insertions, 12 deletions
diff --git a/graphics/swfdec/Makefile b/graphics/swfdec/Makefile
index e8ebb1b69d2c..c74e120069d0 100644
--- a/graphics/swfdec/Makefile
+++ b/graphics/swfdec/Makefile
@@ -7,9 +7,9 @@
#
PORTNAME= swfdec
-PORTVERSION= 0.4.5
+PORTVERSION= 0.5.0
CATEGORIES= graphics
-MASTER_SITES= http://swfdec.freedesktop.org/download/swfdec/0.4/
+MASTER_SITES= http://swfdec.freedesktop.org/download/swfdec/0.5/
MAINTAINER= ports@FreeBSD.org
COMMENT= Flash Rendering Library
@@ -19,23 +19,15 @@ LIB_DEPENDS= mad.2:${PORTSDIR}/audio/libmad \
oil-0.3.1:${PORTSDIR}/devel/liboil
USE_XLIB= yes
-USE_SDL= sdl
USE_GNOME= gnomehack gtk20 gnomevfs2
USE_GSTREAMER= yes
USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-Wl,-Bsymbolic -L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --disable-mozilla-plugin \
- --with-audio=none
+CONFIGURE_ARGS= --with-audio=none
INSTALLS_SHLIB= yes
PLIST_SUB= VERSION=${PORTVERSION:R}
-post-patch:
- @${REINPLACE_CMD} -e "s,int16_t,__int16_t," ${WRKSRC}/libswfdec/swfdec_shape.c
- @${REINPLACE_CMD} -e 's|plugin||g' ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e "s|sdl-config|${SDL_CONFIG:T}|g" \
- ${WRKSRC}/configure
-
.include <bsd.port.mk>