aboutsummaryrefslogtreecommitdiff
path: root/graphics/swfdec
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2008-08-10 23:06:06 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2008-08-10 23:06:06 +0000
commitacc7c83c0bc0166f2706bac1b24c4c0cabaa0e09 (patch)
treede96d9524fdd25beea1f27be899df887bc2fd789 /graphics/swfdec
parent66063fa958bed71646492ed58b0889ca988206ff (diff)
downloadports-acc7c83c0bc0166f2706bac1b24c4c0cabaa0e09.tar.gz
ports-acc7c83c0bc0166f2706bac1b24c4c0cabaa0e09.zip
Only add the ffmpeg CPPFLAGS if not building with gstreamer.
Notes
Notes: svn path=/head/; revision=218384
Diffstat (limited to 'graphics/swfdec')
-rw-r--r--graphics/swfdec/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/graphics/swfdec/Makefile b/graphics/swfdec/Makefile
index 8a352dde5927..951697ec5497 100644
--- a/graphics/swfdec/Makefile
+++ b/graphics/swfdec/Makefile
@@ -20,12 +20,14 @@ LIB_DEPENDS= oil-0.3.0:${PORTSDIR}/devel/liboil \
USE_GNOME= gnomehack gtk20
USE_AUTOTOOLS= libtool:15:env automake:19:env autoconf:261
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/ffmpeg" \
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="-Wl,-Bsymbolic -L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-audio=oss
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
+CPPFLAGS= -I${LOCALBASE}/include
+
OPTIONS= GSTREAMER "Support for decoding some codecs with GStreamer" off
PLIST_SUB= VERSION=${PORTVERSION:R}
@@ -38,6 +40,7 @@ USE_GSTREAMER= yes
LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg \
mad.2:${PORTSDIR}/audio/libmad
CONFIGURE_ARGS+= --disable-gstreamer --enable-ffmpeg --enable-mad
+CPPFLAGS+= -I${LOCALBASE}/include/ffmpeg
.endif
post-patch: