aboutsummaryrefslogtreecommitdiff
path: root/graphics/swfmill
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /graphics/swfmill
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
Notes
Diffstat (limited to 'graphics/swfmill')
-rw-r--r--graphics/swfmill/Makefile5
-rw-r--r--graphics/swfmill/files/patch-readpng.c14
2 files changed, 14 insertions, 5 deletions
diff --git a/graphics/swfmill/Makefile b/graphics/swfmill/Makefile
index e1a0fd71ef2c..b7ba59941843 100644
--- a/graphics/swfmill/Makefile
+++ b/graphics/swfmill/Makefile
@@ -7,13 +7,14 @@
PORTNAME= swfmill
PORTVERSION= 0.3.0
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://swfmill.org/releases/
MAINTAINER= skv@FreeBSD.org
COMMENT= xml2swf and swf2xml processor with import functionalities
-LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
freetype.9:${PORTSDIR}/print/freetype2
USE_AUTOTOOLS= libtool
@@ -25,6 +26,6 @@ CONFIGURE_ENV+= PKG_CONFIG=${LOCALBASE}/bin/pkg-config
USE_LDCONFIG= YES
post-patch:
- @${REINPLACE_CMD} -e 's|libpng|libpng14|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|libpng|libpng15|' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/graphics/swfmill/files/patch-readpng.c b/graphics/swfmill/files/patch-readpng.c
index ba18494b46ea..53c3d44c9172 100644
--- a/graphics/swfmill/files/patch-readpng.c
+++ b/graphics/swfmill/files/patch-readpng.c
@@ -1,6 +1,14 @@
---- src/swft/readpng.c.orig 2006-07-20 15:57:17.000000000 +0200
-+++ src/swft/readpng.c 2010-03-29 16:19:53.000000000 +0200
-@@ -69,7 +69,7 @@
+--- src/swft/readpng.c.orig 2009-11-30 01:18:53.000000000 +0100
++++ src/swft/readpng.c 2012-05-05 07:48:08.000000000 +0200
+@@ -51,6 +51,7 @@
+ #include <stdlib.h>
+
+ #include "png.h" /* libpng header; includes zlib.h */
++#include "zlib.h"
+ #include "readpng.h" /* typedefs, common macros, public prototypes */
+
+ /* future versions of libpng will provide this macro: */
+@@ -87,7 +88,7 @@
* have used slightly more general png_sig_cmp() function instead */
fread(sig, 1, 8, infile);