aboutsummaryrefslogtreecommitdiff
path: root/graphics/swfmill
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2006-09-05 16:47:14 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2006-09-05 16:47:14 +0000
commitae994dc4d69ad841c8e630db88cee59ef5971ad6 (patch)
treef6809082676139295428f3c77b9beb908ad7d05a /graphics/swfmill
parentabc85f6780d6bc99ca25dfce34fda61dca98c95b (diff)
downloadports-ae994dc4d69ad841c8e630db88cee59ef5971ad6.tar.gz
ports-ae994dc4d69ad841c8e630db88cee59ef5971ad6.zip
On 4.x add workaround for <stdint.h>
Pointed by: pointyhat (kris)
Notes
Notes: svn path=/head/; revision=172328
Diffstat (limited to 'graphics/swfmill')
-rw-r--r--graphics/swfmill/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/graphics/swfmill/Makefile b/graphics/swfmill/Makefile
index 8ab5d4ed21c0..6b84c964624a 100644
--- a/graphics/swfmill/Makefile
+++ b/graphics/swfmill/Makefile
@@ -22,9 +22,15 @@ USE_GNOME= pkgconfig libxml2 libxslt
GNU_CONFIGURE= YES
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}" PKG_CONFIG=${LOCALBASE}/bin/pkg-config
-INSTALLS_SHLIB= YES
+USE_LDCONFIG= YES
+
+.include <bsd.port.pre.mk>
post-patch:
@${REINPLACE_CMD} -e 's|libpng|libpng12|' ${WRKSRC}/configure
+.if ${OSVERSION} < 500000
+ ${REINPLACE_CMD} 's:#include.<stdint\.h>:#include <sys/types.h>:' \
+ ${WRKSRC}/src/*.h
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>