aboutsummaryrefslogtreecommitdiff
path: root/graphics/swftools
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2014-01-07 17:42:09 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2014-01-07 17:42:09 +0000
commit8f673303aafa35b9266e0a565ab13c6954042382 (patch)
tree64f4c7ea9d5584fe466da6459006a5225170ad18 /graphics/swftools
parente179a5b3c8d63e15be6f573bc896c356052f296e (diff)
Notes
Diffstat (limited to 'graphics/swftools')
-rw-r--r--graphics/swftools/Makefile18
1 files changed, 7 insertions, 11 deletions
diff --git a/graphics/swftools/Makefile b/graphics/swftools/Makefile
index e592f8e72b14..53bc29ccb03c 100644
--- a/graphics/swftools/Makefile
+++ b/graphics/swftools/Makefile
@@ -22,11 +22,8 @@ LIB_DEPENDS= libt1.so:${PORTSDIR}/devel/t1lib \
NO_STAGE= yes
-OPTIONS_DEFINE= LAME PDF
-
-USES= pkgconfig
+USES= pkgconfig gmake
USE_GL= glut
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_lib_zzip_zzip_file_open=no
@@ -37,22 +34,21 @@ MAN1= as3compile.1 font2swf.1 gif2swf.1 jpeg2swf.1 pdf2swf.1 \
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+OPTIONS_DEFINE= LAME PDF
+OPTIONS_SUB= yes
+LAME_LIB_DEPENDS= libmp3lame.so:${PORTSDIR}/audio/lame
+PDF_LIB_DEPENDS= libpdf.so:${PORTSDIR}/print/pdflib
+
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MLAME}
-LIB_DEPENDS+= mp3lame.0:${PORTSDIR}/audio/lame
-.else
-#CONFIGURE_ARGS+= --disable-lame
+.if ! ${PORT_OPTIONS:MLAME}
CONFIGURE_ENV+= ac_cv_lib_mp3lame_lame_init=no
.endif
.if ${PORT_OPTIONS:MPDF}
-LIB_DEPENDS+= pdf.6:${PORTSDIR}/print/pdflib
-PLIST_SUB+= PDF=""
MAN1+= pdf2pdf.1
.else
CONFIGURE_ENV+= ac_cv_lib_pdf_PDF_open_file=no
-PLIST_SUB+= PDF="@comment "
.endif
post-patch: