aboutsummaryrefslogtreecommitdiff
path: root/graphics/synaesthesia/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-03-15 16:18:19 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-03-15 16:18:19 +0000
commit32083af36bc9eed399cb3ec4e3dde65445531a50 (patch)
tree8c3988cc66bdff98b13895d12c71e323af51d571 /graphics/synaesthesia/Makefile
parentd3197732e3e68806152838936bd5c26396b928f9 (diff)
downloadports-32083af36bc9eed399cb3ec4e3dde65445531a50.tar.gz
ports-32083af36bc9eed399cb3ec4e3dde65445531a50.zip
Notes
Diffstat (limited to 'graphics/synaesthesia/Makefile')
-rw-r--r--graphics/synaesthesia/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/graphics/synaesthesia/Makefile b/graphics/synaesthesia/Makefile
index 028e2de460cd..7bec07c3fd32 100644
--- a/graphics/synaesthesia/Makefile
+++ b/graphics/synaesthesia/Makefile
@@ -1,4 +1,4 @@
-# Created by: petef@FreeBSD.org
+# Created by: Pete Fritchman <petef@FreeBSD.org>
# $FreeBSD$
PORTNAME= synaesthesia
@@ -8,14 +8,15 @@ CATEGORIES= graphics audio
MASTER_SITES= http://www.logarithmic.net/pfh-files/synaesthesia/
MAINTAINER= ports@FreeBSD.org
-COMMENT= Graphically represents sound in real time
+COMMENT= Real-time graphical music representation program
LICENSE= GPLv2
-USE_SDL= sdl
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-sdl-prefix=${LOCALBASE}
+USE_SDL= sdl
+
PORTDOCS= README
PLIST_FILES= bin/${PORTNAME}
@@ -24,17 +25,15 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
post-patch:
- @${REINPLACE_CMD} -e 's,stdint.h,inttypes.h,' ${WRKSRC}/*.c?
+ @${REINPLACE_CMD} -e 's,stdint\.h,inttypes.h,' ${WRKSRC}/*.c?
@${REINPLACE_CMD} -e 's,int16_t,u_int16_t,' ${WRKSRC}/sound.cc
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-PLIST_FILES+= %%DOCSDIR%%/README
-PLIST_DIRS+= %%DOCSDIR%%
.endif
.include <bsd.port.mk>